Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[url=admin]the CMS[/url]


Reply


5 Posts   692 Views

Avatar
Josua

Community Member, 86 Posts

18 February 2012 at 8:12am

Edited: 18/02/2012 8:19am

Hello!

I installed the blog module.
The installation create an example blog with the following text:
----------------------------
Congratulations, the SilverStripe blog module has been successfully installed. This blog entry can be safely deleted. You can configure aspects of your blog (such as the widgets displayed in the sidebar) in [ url=admin ]the CMS[ /url ].
(Note: I put the spaces in [ url=admin ]the CMS[ /url ], because here it appears as a link)
----------------------------
When you see the text in the frontend, the link 'the CMS' is not show as a link, show [ url=admin ]the CMS[ /url ].

Why is this?
Do I have to connect something or install something else?

Thanks,
Regards,
Jose A.

Avatar
Willr

Forum Moderator, 5513 Posts

20 February 2012 at 7:36pm

[command] is bbcode which the blog module supports but sounds like you have WYSIWYG enabled rather than BBCode.

Avatar
Josua

Community Member, 86 Posts

21 February 2012 at 12:33am

Edited: 21/02/2012 1:26am

Hello Will,

I downloaded the blog module from https://github.com/silverstripe/silverstripe-blog

In my _config.php I don`t have BlogEntry::allow_wysiwyg_editing();
so should work with BBCode.

The only way I found to make it work with BBCode is adding this line to my _config.php
BlogEntry::$allow_wysiwyg_editing = false;

But should work by default with BBCode.
Is this correct?

Do I have to add that line to my _config.php?

Thanks,
Regards,

Jose A.

Avatar
Willr

Forum Moderator, 5513 Posts

22 February 2012 at 5:55pm

You can only use one of WYSIWYG or BBCode, not both. By default WYSIWYG is the enabled option (https://github.com/silverstripe/silverstripe-blog/blob/master/code/BlogEntry.php#L43) so yes, if you want to use BBCode you'll have to keep that line in your _config file.

Avatar
Josua

Community Member, 86 Posts

22 February 2012 at 9:02pm

Ok.
Will thank you very much.

Regards,
Jose A.