Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[SOLVED] SS 3.03 - Blog module wont use some translations


Reply

523 Views

Avatar
borriej

21 December 2012 at 11:59pm (Last edited: 22 December 2012 12:07am), Community Member, 267 Posts

Hi all,

I'm using a custom translation file. nl.yml
path: mysite/lang/nl.yml

nl:
ArchiveWidget.ss:
FILTERDATE: "Filter op datum"
Home.ss:
READMORE: "LEES MEER"
BlogHolder.ss:
NEWSOLDER: "Oudere berichten"
VIEWINGPOSTEDIN: "Berichten geplaatst in"
VIEWINGTAGGED: "Berichten getagd met"
BlogSummary.ss:
VIEWFULL: "Lees dit bericht:"
POSTEDBY: "Geplaatst door"
POSTEDON: "Toegevoegd op:"
VIEWFULL: "Bekijk het gehele post getitled"
COMMENTS: "Reacties"
VIEWCOMMENTS: "Bekijk reacties"
VIEWTAGS: "Bekijk alle berichten met tag:"
READMORE: "LEES MEER"
BlogEntry.ss:
POSTEDON: "Toegevoegd op:"

but some translation don't get used, others do get used. So the file is found.

example:
ArchiveWidget - FILTERDATE - works
Home - READMORE - works
BlogSummary.ss - POSTEDON - works
BlogSummary.ss - VIEWTAGS - works

but:
BlogEntry.ss - POSTEDON - doens't work
BlogHolder.ss: - NEWSOLDER - doens't work
BlogHolder.ss: - VIEWINGPOSTEDIN - doens't work
BlogHolder.ss: - VIEWINGTAGGED - doens't work

if it doesn't work, i mean it uses the default lang file in the blog module

any idea's?
i am using spaces instead of tabs off course, but i see the topic doens't show them.. see http://paste2.org/p/2629327

UPDATE: guess my mark-up went wrong in the last sentence, only noticed it when i pasted the code on paste2.org, apparently it missed all the spaces although Espresso was showing them :s