Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Blog Module

Discuss the Blog Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Error at line 1324 of /framework/model/DataObject.php


Reply

5 Posts   1009 Views

Avatar
albere

15 January 2013 at 7:11am Community Member, 6 Posts

I can view the articles I created earlier for the blog module but I can no longer access the blog holder page in admin. I get the error:
Error at line 1324 of ...../framework/model/DataObject.php

Anyone had any experience of this error? Just looking for clues.

Avatar
Pix

25 January 2013 at 7:51am (Last edited: 25 January 2013 7:54am), Community Member, 145 Posts

Did you install the widget module? I am getting the same error after installing the widget module in SS 3.0.3. If I remove the widget module and rebuild, the error goes away.

Disappointing. I should have just stuck with SS 2.4.7, so far SS3 makes me sad. I love the new admin, but after dealing with performance issues and all of these little problems I need a drink.

Avatar
Pix

25 January 2013 at 9:01am Community Member, 145 Posts

You might try the branch of the blog moduleon github 'ss3-fixes', it seems to have fixed the issue for me:

https://github.com/silverstripe/silverstripe-blog/tree/ss3-fixes

Avatar
s_a_m_y

30 January 2013 at 1:49am Community Member, 25 Posts

Same problem here with a fresh install. Tried the blog-fix but now I get a new error message.

[User Warning] None of these templates can be found in theme ": WidgetAreaEditor.ss
GET /admin/pages/edit/show/8
Line 670 in /framework/vier/SSViewer.php

Source
if(!$this->chosenTemplates){
$templateList=(is_array($templateList)) ? $templateList:array($templateList);

user_error("Noe of these templates can be found in theme""
.self::current_theme()."":".implode(".ss,",$templateList).".ss,E_USER_WARNING);
}

This message will only show after a reload of BlogHolder (admin panel) for a second and then somehow autoscrolls down to the admin area which oddly enough still is displayed. I cannot scroll up to the top of the page to read the error message nor can I scroll down to the area where I can usually save changes to the page. So I only get to see a limited part of the page.

The error messages to me hints more in direction of a widget-module problem rather than a blog problem. I am not a code crack so I am pretty lost here and require different blog widgets for a project. Would rather stick to SS3. Anyone else experience this and found a solution?

Thanks,
Samy

Avatar
s_a_m_y

30 January 2013 at 2:22am Community Member, 25 Posts

Ok. Did get it solved after a fresh install and then using the fixed blog. Apparently "updating" the files and running a dev/build and flush didn't do it...