Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Connect With Other SilverStripe Members /

For all SilverStripe-related topics that don't fit into any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

processes\process director URL and custom pages error [solved]


Reply


2 Posts   726 Views

Avatar
Xananax Prozaxx

Community Member, 11 Posts

2 May 2011 at 11:05am

I just wanted to post this in the (odd) case that someone runs in the same problem I did.
I had a custom class extending page called "Processes" that could contain any number of children DataObjects "process".
When I would add "processes" to my menu and click on it, I would get a Blank Screen of Death.

But calling the "Process" objects from a custom function worked. And my "processes" class contained only an $allowed_children directive!
Boy I had a hard time debugging this.

Turns out, in the _config.php located in /cms/ there is this line:
Director::addRules(50, array(
   'processes//$Action/$ID/$Batch' => 'BatchProcess_Controller',....)

So "processes" is actually a reserved keyword.
Just in case someone has the same idea...Rename your holder class "processesHolder" or "procedures"

Avatar
Xananax Prozaxx

Community Member, 11 Posts

2 May 2011 at 11:15am

Or, more simply, change the path from the cms admin panel for that particular page