Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Content Editor Discussions

Forum for content editors and CMS users.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Using the CMS with iPad


Reply

5 Posts   2189 Views

Avatar
Ryan M.

6 December 2011 at 12:06pm Community Member, 309 Posts

It's time to resurrect this issue. With the release of iPad 2 and the fact that it's been about a year since anyone last talked about the CMS + iPads (at least, that's what my search turned up).

Has anyone had any luck running the CMS flawlessly on the iPad lately? I don't own one myself, so I'm wondering.

Avatar
martimiz

1 January 2012 at 1:27am (Last edited: 1 January 2012 1:31am), Forum Moderator, 1091 Posts

At first I gave up right away because I couldn't get TinyMCE to work consistently. Later I found I can at least edit some text - as long as I don't move the cursor while the keyboard is active, so: hide the keyboard then try to position the cursor in one go. Doable but no party.

the CMS responds quickly, no problems there, and saving a page is no problem. Of course file uploads are not available. DOM seems to be working so far, haven't tried anything else so far, as I see this somewhat as a last resort...

[EDIT] hey, I see the new year has already started up in NZ.. Here we still have some 10,5 hours to go... Have a good one SilverStripers, cheers!!!

Avatar
Bruce B

14 March 2012 at 4:43pm Community Member, 145 Posts

Just tried with the latest version of iOS (5.1) and SS 2.4.7 on a 1st gen iPad. I didn't do a full test but I could edit text in TinyMCE quite happily. Moving the cursor while the keypad was showing worked fine and I could save the resulting page. Everything 'just worked' so Apple must have been busy with fixes in that last update.

This isn't a full test so I wouldn't be saying to clients its fully compatible with the iPad but certainly I'd say is quite usable with limitations e.g. no file upload. (but adding an image already in assets was OK.)

Avatar
swaiba

15 March 2012 at 1:59am Forum Moderator, 1796 Posts

Not 2.4.x, but still relevant I think...

https://groups.google.com/forum/?fromgroups#!topic/silverstripe-dev/5J1xUap5y9g

Avatar
martimiz

19 March 2012 at 12:48am Forum Moderator, 1091 Posts

Can't follow that link from my ipad neither :)

Just tried TinyMCE from pad ii with v3 - still the same issue, have to exit keyboard on cursormove to be able to type again..