Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Content Editor Discussions /

Forum for content editors and CMS users.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

site not working properly in Internet Explorer


Reply


5 Posts   2730 Views

Avatar
Pieta

Community Member, 4 Posts

29 March 2009 at 2:31pm

Edited: 29/03/2009 2:32pm

My site has been developed in Firefox and of course is great in that environment. There are however multiple problems for IE users which is probably most of my customer base. Eg Not all of the secondary navigation shows on some pages; The pages don't scroll down; The comments don't show or are out of place etc. I am talking IE version 7 and others unknown.

The site uses the paddy Green theme. Any suggestions? Thanks.

Avatar
Carbon Crayon

Community Member, 598 Posts

30 March 2009 at 6:25am

Hi Peita

The common solution to this problem is to create a separate style sheet for IE6 and and another for IE7 and then conditionally include them by putting this in your header:

   <!--[if IE 6]>
         <style type="text/css">
          @import url(themes/yourtheme/css/IE6.css);
         </style>
   <![endif]-->

   <!--[if IE 7]>
         <style type="text/css">
          @import url(themes/yourtheme/css/IE7.css);
         </style>
   <![endif]-->

Hope that helps :)

Avatar
Pieta

Community Member, 4 Posts

30 March 2009 at 11:37am

Many thanks. Will give it a go.

Avatar
Pieta

Community Member, 4 Posts

31 March 2009 at 12:23pm

I am told I still have to create the new IE6 and IE7, and probably now IE8 CSS pages. Can someone help me with how to do this. Thanks

Avatar
DanStephenson

Community Member, 115 Posts

19 April 2009 at 4:49am

Edited: 19/04/2009 4:49am

You create those stylesheets like you would create any "normal" stylesheet, in the text editor of your choice. Just give them a different name.