Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Customising the CMS

Disabling prototype for page comments


Reply

2 Posts   2148 Views

Avatar
Anatol

11 February 2010 at 4:14pm (Last edited: 11 February 2010 4:15pm), 126 Posts

Hi,

just in case this might help anyone. I'm building a site that uses the [url=http://mootools.net/]Mootools[/url] framework (in the frontend). It all works well, but when I allow comments on a page Silverstripe adds javascript validation with the Prototype JS framework. This creates a conflict with Mootools. You may run into similar problems with other frameworks such as jQuery.

To get rid of Prototype you need to disable both AJAX commenting (in _config.php):

PageCommentInterface::set_use_ajax_commenting(false);

and remove the form validation (in e.g. Page.php):

class Page_Controller extends ContentController {
   
   public function init() {
      parent::init();
      Validator::set_javascript_validation_handler('none');
   }

Cheers!
Anatol

Avatar
Andrew Houle

24 February 2011 at 6:45am Community Member, 132 Posts

Thanks for taking the time to post this! I was running into the same issues (predictably so) with the jQuery library.

Andy