Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Customising the CMS /

Gridfield - Save and add another


Go to End
Reply


12 Posts   2414 Views

Avatar
Willr

Forum Moderator, 5513 Posts

22 June 2013 at 7:32pm

buttons are turning up on my add or edit pages for gridfield records.

The buttons don't automatically show up AFAIK, you have to edit the PHP code to add the fields to the objects you need them on.

Avatar
Rossel

Community Member, 18 Posts

4 July 2013 at 4:45pm

botheredbybees or anyone else who finds this.
If you are using SS 3.0 you need to make sure you get the silverstripe-gridfield-betterbuttons 3.0 Branch code off github: [url]https://github.com/unclecheese/silverstripe-gridfield-betterbuttons/tree/3.0[/url] , The download only seemed to grab the latest master version, so you might have to copy and past the 3.0 branch code and replace anything that is different. But it works now.
thank f*k.

Willr - Also didnt need to add any additional php code. just upload & dev/build?flush=all

Avatar
cSGermany

Community Member, 37 Posts

2 September 2013 at 6:24pm

Hi,

I also have a problem with it. If got two Silverstripe sites - better buttons is working on my private page and i thought it would be great for the companypage i'm working on.

Both are running Sivlerstripe 3.0.5.

I downloaded the betterbuttons directory from my private site and uploaded it to the company page. Than I ran a dev/build?flush=1 and tried it. But it wont work there :/

What can I do?
Any Ideas how to debug?

Thx in advance
cSGermany

Avatar
kindlemanwill

Community Member, 68 Posts

11 September 2014 at 4:26pm

Did you guys get it working? I thought i had some trouble with it, but after some time realised the buttons don't show on create record - just edit. Hopefully that helps someone.

Go to Top