Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Customising the CMS /

2.3: Language mix in admin area


Go to End
Reply


18 Posts   4334 Views

Avatar
wagnerma

Community Member, 12 Posts

5 March 2009 at 1:06am

I have changed the admin language from en to de. On my local system, all is fine, but at the live system at the webhoster, the admin area consists of a language mix of english and german translations. Reinstalling/Flushing/Rebuilding always the same picture, a nice mixture of both languages in the admin area. The same with other languages, and also the same fields, that are not translated. For example the top navigation bar with Site Content,Files & Images,Comments,Security, Help never changes to the selected language.

Any ideas what's wrong? Seems like a bug?

Thanks for the help,

Marcel

Avatar
Ultimate

Community Member, 18 Posts

11 March 2009 at 2:04am

Same problem here. And there is another oddity, though I dont't know if it has anything to do with the mixture-problem. When I'm setting the CMS-language in the profile-window the OK-button has no caption and is just blank. Clicking this no-captioned button SS opens the home page inside the profile window. really strange.

Attached Files
Avatar
Ingo

Forum Moderator, 801 Posts

15 March 2009 at 8:14am

Hm, can't reproduce on a 2.3 installation in live mode when switching CMS to german in my profile. Can you confirm that your Member record in the database has the correct "Locale" setting? Do you have the files cms/lang/de_DE.php and sapphire/lang/de_DE.php in your live installation? Perhaps its a case-sensitivity issue?

Avatar
wagnerma

Community Member, 12 Posts

16 March 2009 at 10:31pm

Checked all, member record has the correct language setting 'de_DE' and the files have no case sensitive problems. It also doesn't depend on a specific language (in my case german), same in other languages. The files are all found and used. Some words are translated correct, for example in the member panel, the table heads are 'Firstname','Nachame','Email','Password'. Strange?

And same here, when editing a member record, the "Ok" Button has also no text and so is very small.

Is silverstripe using a language information from the operating system it is runnig on? My live system is running on an english system, my developer machine is german, where I don't see the problem?

Any other things I can check?

Thanks,

Marcel

Avatar
Ingo

Forum Moderator, 801 Posts

20 March 2009 at 10:41am

The backend locale is determined by your profile (/admin/myprofile), and falls back to the default en_US.
I just tried again, the table headers in /admin/security work fine for me in German on a 2.3 install - its a bit of a mystery...
particularly the "partially missing" translations - I mean, either the $lang array is loaded from the locale file or it isnt...very strange.
What OS, browser and server environment are you running on?

Avatar
wagnerma

Community Member, 12 Posts

25 March 2009 at 8:55am

Indeed very strange, I see nothing wrong ;-(

The server env: Apache/2.2.3 (Debian) DAV/2 SVN/1.4.2 PHP/5.2.8
The Client: Firefox 3.0.7/IE7 on Windows XP SP3

My local server env: Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8

There is all right, my live server do it wrong ;-(

You can also see the problem on the live site:

http://www.wagnerecht.de/www/admin

There you see the language mix in the admin login dialog, all is german, one sentence is english. On my developer pc all is german ;-(

Any other ideas ??

Thanks a lot for your feedback!

Marcel

Avatar
janulka

Community Member, 80 Posts

25 March 2009 at 11:32am

subscr.

Avatar
Ingo

Forum Moderator, 801 Posts

25 March 2009 at 12:52pm

Tested the login box on a clean 2.3 install with i18n::set_locale('de_DE'); in mysite/_config.php, worked out fine, meaning I see the german text in Security/login. Wagnerma, please try a new 2.3 with only this _config.php addition to rule out any setup errors.

Go to Top