Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Customising the CMS /

Adding xml driven flash mp3 player in SS


Reply


2 Posts   2520 Views

Avatar
Anaya

Community Member, 42 Posts

31 March 2009 at 11:50pm

Hi Guys

I am enjoying learning SS.
One of my clients wants MP3 Player to play her music on a website.
I have bought xml driven MP3 Player which takes xml file as a playlist.
Adding that flash player using <object> and <embed> tags. In xml file, path to actual songs is specified.
XML file, flash player and song's folder all are stored at location jsparty/player/.
But some how its not working. I am storing these files at worng location or what?
Have tried the code mentioned in one of the threads about adding Audio through CMS.
But that also does not work
In short I dont have any idea about how to get this working?
Need your expert advice.......

Regards
Anaya..

Avatar
Mo

Community Member, 510 Posts

10 June 2009 at 9:14pm

Could you give some more details?

What isn't working? Is the audio player loading, but not playing? Is it not loading at all? Is it showing just your alternate flash content?

If the player isn't loading at all, then the <object> is probably not finding the flash file, or there could be a permissions error.

If the songs aren't playing, then the audio player might not be able to find your XML playlist.

Also, what version of Silverstripe are you using?

Cheers,

Mo