Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Customising the CMS /

Trying to add flickr badge and getting this error.


Go to End
Reply


11 Posts   2276 Views

Avatar
banal

Community Member, 901 Posts

30 July 2009 at 1:17am

Nope, the flickr_badge_beacon can't be the problem imo. I suggest you try this outside of silverstripe in a very basic/plain html page... just to find out if it's a SilverStripe <> Flickr issue, or if it's a general integration issue.
As far as I can tell, you wouldn't need the css either, you should see some loaded images in a plain html page even without the styles.

Avatar
Daimz

Community Member, 36 Posts

30 July 2009 at 6:24pm

So I think it is a Silverstripe problem. It works just as it should in a plain html page.
[url]http://www.arctosdesign.com/flick.html[/url]

so now what? Is there anyway to fix this problem or will I have to find another script?

Avatar
Daimz

Community Member, 36 Posts

30 July 2009 at 7:12pm

Someone over at smashing magazine said the problem might be with the mime types:

I took a look at the Flickr code and discovered that it's using document.write to dump the code on to the page... document.write does not work in XHTML. The reason it works on those other sites is that they are serving their XHTML files with the text/html mime (which puts it in HTML mode instead of XHTML mode) instead of the application/xhtml+xml mime as you are doing.

I am not exactly to sure what he is meaning but the website he is refering to other than mine is http://www.abduzeedo.com

Is there a way to change the mime types in Silverstripe? and is that what I am even meant to be doing?

Go to Top