Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Data Model Questions

Couldn't get Site Tree1


Reply

4 Posts   2055 Views

Avatar
delcon

28 May 2010 at 12:01am Community Member, 9 Posts

Hi

I have a problem with control children

when called control children, sapphire throws an error:

Error at \sapphire\core\model\Versioned.php line 853: Versioned::get_version: Couldn't get SiteTree.1

Pages seam to be ok in Admin...

How could I trace this problem?

Tried to create a new ListPage with new children doesn't help....

delcon

Avatar
MonkeyFish

21 April 2011 at 12:01pm Community Member, 12 Posts

I had a similar problem. Ran /dev/build/?flush=1 and ran the following mysql query REPAIR TABLE SiteTree using PHPMyAdmin. Not sure what fixed it but i suspect it was a corrupt SiteTree table.

Avatar
johnmblack

19 May 2011 at 2:25am Community Member, 61 Posts

Alternate solution, from: http://silverstripe.org/releases-and-announcements/show/13992

"I have just had this problem. I found the cookie was the problem. Clear your cookies and you should be able to re-login using the same browser"

Avatar
MartinPhone

15 May 2013 at 12:40pm Community Member, 57 Posts

I had this same problem - I found I had links to pages that weren't there any more/had their page type changed slightly. Possibly not the best solution but I just went through and updated the links... repairing and clearing cache didn't work for me...