Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

[User Error] Uncaught Exception: Object->__call(): the method 'backlinktracking' does not exist on 'ImageGalleryImage'


Go to End
Reply


11 Posts   3765 Views

Avatar
Kinkykoder

Community Member, 8 Posts

26 November 2009 at 7:25am

Hi, I thought I'd better post this in the correct forum rather than hijack someone's 'old' gallery thread in General.

I've been trying to get ImageGallery working all day, but I just can't get importing to work.

If I click 'Upload Images' and select a file, then open, nothing happens.

If I select a folder to 'import from existing folder', I get:

[User Error] Uncaught Exception: Object->__call(): the method 'backlinktracking' does not exist on 'ImageGalleryImage'

I read several threads concerning the above error, so I downloaded the latest source from your repository for:

- dataobject_manager
- image_gallery
- swfupload

I also made the change to FileDataObjectManager.php as shown in:
http://www.silverstripe.org/dataobjectmanager-module-forum/show/269282?start=24
(which isn't in the latest source)

and did a dev/build?flush=1

Is there anything else I need to change?

Many thanks.

BTW - if I try to 'import from an existing folder' within Files & Images, it works - although I get an out of memory error if a select many at once. My php memory is 90MB. But still, I can't find any way to get images into an ImageGallery.

Avatar
UncleCheese

Forum Moderator, 4096 Posts

26 November 2009 at 7:52am

Whoops. Just checked in a fix for you. Run an update an you should be good.

Avatar
Kinkykoder

Community Member, 8 Posts

26 November 2009 at 9:56am

Thanks so much for that UncleCheese, the 'import from an existing folder' now works a treat on Safari, so I've managed to get some photos in and the live gallery looks great :-)

I now get the following problems though:

- The 'Upload Images' button on Safari does nothing after selecting a file.
- On IE8 it does show a progress bar, but gives script error when clicking Upload:

> Type Error: Object doesn't support this property or method

In IE8, on every load / step of a popup dialog (Add Album and Add Images To...) I get the following script error:

> Not implemented
> dataobjectmanager_popup.js, line 8 character 3

(function($) {
$(function() {
$('body').removeClass('loading');

      iframe_height = window.parent.jQuery('#facebox iframe').height(); // - 82;
diff = $('body').height() - $('#field-holder').height();
fields_height = (iframe_height - diff)-50;
      top = fields_height + diff-21;
      

Thanks again for your help!

Avatar
UncleCheese

Forum Moderator, 4096 Posts

26 November 2009 at 12:07pm

I can't replicate the Safari issue. The IE8 issue I'm aware of and working on. I think it requires changing modal windows because Facebox is not IE8 compatible.

You might try this fix here:

http://www.silverstripe.org/dataobjectmanager-module-forum/show/267007?start=16#post273932

Avatar
Kinkykoder

Community Member, 8 Posts

27 November 2009 at 7:17am

Thanks, I tried the search replace in facebox.js, but it didn't seem to make any difference in IE8. In Safari (4.0.4), it now does show the progress bar, but gives the following error on clicking Upload:

> TypeError: Result of expression 'form.onsubmit' [null] is not a function.

Anyway - everything in the CMS now works with Firefox and everything on the live site works on all latest browsers so I'm very happy. I've just told my client that they must use Firefox to update their site / galleries.

Thanks for your help with this!
Cheers, Andrew

Avatar
BLU42 Media

Community Member, 71 Posts

5 May 2010 at 5:01am

Hi-

I'm attempting to use the 'use existing folder' option and I'm still seeing the "backlinktracking does not exist" error message. I'm running SS 2.3.7 with the latest build (r395) of DOM. Any ideas?

Thanks!
John

Avatar
UncleCheese

Forum Moderator, 4096 Posts

5 May 2010 at 5:06am

Careful.. the latest rev of DOM doesn't work with 2.3. See the "2.3 Branch" sticky.

Avatar
BLU42 Media

Community Member, 71 Posts

5 May 2010 at 5:10am

Ah, okay... I'll roll that back. I was getting the error with r394 too.

Go to Top