Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

ffmpeg not working -SOLVED-Thanks UncleCheese


Go to End
Reply


13 Posts   4283 Views

Avatar
Rishi

Community Member, 97 Posts

24 January 2010 at 8:53am

Edited: 30/01/2010 7:37am

Hello
In my server ffmpeg is installed and its workign fine when I am using it in simple php file but when i am trying in silverstripe its giving me no such file in ffmpeg log file
i have set the path in _config.php file also
Any help??

Avatar
Rishi

Community Member, 97 Posts

27 January 2010 at 6:20pm

Edited: 27/01/2010 10:14pm

any help????

Avatar
UncleCheese

Forum Moderator, 4096 Posts

28 January 2010 at 3:01am

What happens when you run FLV::echo_ffmpeg_test()?

Avatar
Rishi

Community Member, 97 Posts

28 January 2010 at 6:32pm

Edited: 29/01/2010 1:06am

Hello
I have written
FLV::echo_ffmpeg_test();
echo exec('ffmpeg');

i got this in return

FFMPEG is installed on your server and working properly. Code:

Any idea why it is not working

this is the error message i am getting in ffmpeg log file

[2010-01-28 05:19:31] /usr/bin/ffmpeg-y -i /home/equestri/public_html/silverstripe/assets/Uploads/zz.flv -an -s 640x480 -ss 10 -an -r 1 -vframes 1 -y -vcodec mjpeg -f mjpeg /home/equestri/public_html/silverstripe/assets/video_thumbnails/zz.jpg
[2010-01-28 05:19:31] sh: /ffmpeg-y: No such file or directory

Just a thought
i am using this command to use ffmpeg in my php file directly and its working file

shell_exec('ffmpeg -i japanesecat.wmv japanesecat.flv');

it means i may not need to set any path and can directly run the command ffmpeg in silverstripe also,but when i run silverstripe without setting any path then also it gives me the same error in log file

I have talked with support guy of my server what he was saying is there is no space between the ffmpeg command and its argument i,e between /ffmpeg and -y and there should be a space
/ffmpeg-y: No such file or directory

hope this infomation helps in solving the problem

Avatar
UncleCheese

Forum Moderator, 4096 Posts

29 January 2010 at 9:37am

Well no space after ffmpeg would certainly cause problems, but I don't see anywhere in the code that indicates that should be happening. You said you were on the latest rev, correct?

As a proof of concept, try changing line 281 of /code/flv/FLV.php to have a leading space:

         $args = sprintf(" -y -i %s -an -s %s -ss %d -an -r 1 -vframes 1 -y -vcodec mjpeg -f mjpeg %s",

The ffmpeg_root stuff gets tricky. In my experience, systems will either work with it, or without it, but never both.

Avatar
Rishi

Community Member, 97 Posts

29 January 2010 at 5:48pm

Edited: 29/01/2010 6:04pm

I do have the latest build which i have saved page by page , i have tried using a svn client but that ask for a username and password which i dont no i have tried clicking on cancel but i am not been able to download it.

is it possible to write the ffmpeg command simple like what i am doing in core php
shell_exec('ffmpeg -i japanesecat.wmv japanesecat.flv');

like writting this command in pfl file like this
shell_exec('ffmpeg -i variablename variablename.flv');

just a thought

Avatar
Rishi

Community Member, 97 Posts

30 January 2010 at 2:38am

Edited: 30/01/2010 3:03am

hello UncleCheese
now i have not getting any error message but flv are not creating,in log file i have this

[2010-01-29 14:18:43] ffmpeg -y -i /home/equestri/public_html/silverstripe/assets/Uploads/zz2.flv -an -s 640x480 -ss 10 -an -r 1 -vframes 1 -y -vcodec mjpeg -f mjpeg /home/equestri/public_html/silverstripe/assets/video_thumbnails/zz2.jpg
[2010-01-29 14:18:43] FFmpeg version 0.5, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --incdir=/usr/include --extra-cflags=-fPIC --enable-libamr-nb --enable-libamr-wb --enable-libdirac --enable-libfaac --enable-libfaad --enable-libmp3lame --enable-libtheora --enable-libx264 --enable-gpl --enable-nonfree --enable-postproc --enable-pthreads --enable-shared --enable-swscale --enable-x11grab
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 0 / 52.20. 0
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Nov 6 2009 19:11:04, gcc: 4.1.2 20080704 (Red Hat 4.1.2-46)
/home/equestri/public_html/silverstripe/assets/Uploads/zz2.flv: no such file or directory

Avatar
UncleCheese

Forum Moderator, 4096 Posts

30 January 2010 at 3:39am

What kind of file did you upload?

Go to Top