Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

video not showing in the pages


Reply


33 Posts   4609 Views

Avatar
GRiiDWeb

Community Member, 60 Posts

20 June 2011 at 4:54am

Many thanks again Uncle Cheese.

That's just what I needed. Your advice is appreciated again.

Avatar
GRiiDWeb

Community Member, 60 Posts

20 June 2011 at 7:40am

A possible client has asked if they can set the size of the video window via the cms admin.
I'm not sure where the best place to start is. Is this something that can be done?

It's not that important if it's over complicated

Thanks
GW

Avatar
GRiiDWeb

Community Member, 60 Posts

23 June 2011 at 9:45pm

Hi again.
Another question. The video page works great for me, however i'd like to add multiple video to a page in a similar fashion to the image gallery.
Is there any code/method to be able to acheive this without massive re-programming?

Thanks
GW

Avatar
Mark1

Community Member, 6 Posts

6 July 2011 at 7:55pm

Hello UncleCheese! Thank you for your efforts and beautiful modules you've done!

I'd like to ask for a little help, and to offer my little help as well =)
/ I'm an absoulte beginner, so what extends and decorates what - is a nightmare for me so far /

Problem: I get a tab 'Videos' only in a page type 'Video page'. And your screencasts, along with the code samples I see, make me think, that that tab should be present in all page types.

Question: how do I make it present in all page types?
---------------------------
I'd like to offer you translation of your modules into russian/ukrainian. That's just to do something in turn=)

BTW: I have comments/suggestions on how to amend Docs for DataObjectManager Module. Because this thread helped me more, than the original Doc.

Avatar
UncleCheese

4085 Posts

8 July 2011 at 9:10am

Just move the code to the Page class.

--------------------
SilverStripe tips, tutorials, screencasts and more: http://www.leftandmain.com

Avatar
Mark1

Community Member, 6 Posts

8 July 2011 at 8:33pm

Edited: 09/07/2011 12:00am

UncleCheese, I see that 'Page class' is in \mysite\code\Page.php. But what code to move, and where? From video.php/videopage.php/both? I was trying to move from videopage.php to Page.php, inside function 'class Page extends SiteTree {}'
I've made many attempts, but failed, it took me days now(((
Or just pls explain the logic, this could also help immensely =) Because I 'd like to add your ImageGallery to other page types, and the problem is the same there.

Avatar
stevanovich

Community Member, 60 Posts

8 July 2011 at 11:22pm

Can anyone let me know if ffmpeg is requried for VideoThumbnail() and VideoPopup() function?

Avatar
Mark1

Community Member, 6 Posts

8 July 2011 at 11:57pm

Edited: 08/07/2011 11:59pm

Can anyone let me know if ffmpeg is requried for VideoThumbnail() and VideoPopup() function? Search shows, that ffmpeg IS requried for VideoThumbnail(). And IMO, FFMPEG is also required for VideoPopup(), UncleCheese called this function a 'Magic feature' in his video, hinting that it does a couple of things at a time (including the first, 'VideoThumbnail()')

UncleCheese's Video on FFMPEG is here : http://www.youtube.com/watch?v=12iZM1IZ8Ec&NR=1