Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Install SWFUpload


Reply


8 Posts   2303 Views

Avatar
suntrop

Community Member, 131 Posts

12 April 2010 at 9:35pm

Hi all

I installed the DataObjectManager and uploaded the SWFUpload folder as well. But the SWFUpload doesn't work - it seems I haven't installed it correctly. (Error: DataObjectManager requires the SWFUpload module.)

I placed the 'swfupload' folder into the root (the folder contains Documentation, Flash, plugins and a swfupload.js). Right place?

I read here at the formus to write

SWFUploadConfig::debug();

into the config. I get: Class 'SWFUploadConfig' not found

Where do I have to move the 'swfupload' folder? Underneath the 'dataobject_manager' folder? Or is there a config file I mus edit before?

Hope somebody can help.

Avatar
UncleCheese

4086 Posts

13 April 2010 at 2:39am

Did you install the SWFUpload module? Where did this "swfupload" folder come from?

Avatar
suntrop

Community Member, 131 Posts

13 April 2010 at 5:38am

Ohhm … I think I did't. I downloaded the SWFUpload from its website (actually the google code website). I belive I followed a link in the docs.

However, where can I download the correct fies? I can't find a module called SWFUpload in the Extensions library here at SilverStripe.

Thanks!
suntrop

Avatar
UncleCheese

4086 Posts

13 April 2010 at 6:41am

Edited: 13/04/2010 6:41am

No, you downloaded the wrong thing.

http://www.silverstripe.org/swfuploadfield-module/

Avatar
suntrop

Community Member, 131 Posts

13 April 2010 at 8:06am

UncleCheese thanks for your help!

I downloaded the files and it works just fine. I think it's a good idea to give users a note in the docs about that. Maybe I am not the only one who downloads the wrong files. The module isn't in the list of modules (did a search on swfupload and can't find it).

Avatar
UncleCheese

4086 Posts

13 April 2010 at 8:46am

For some reason, it's listed as "unsupported", which I don't understand. That makes it not show up in the default search. I don't have control over that property, unfortunately. I'll ask SS about it.

Avatar
TF-35Lightning

Community Member, 137 Posts

29 April 2010 at 8:36pm

Hi uncle cheese yes I ran the same gauntlet as suntrop and thought i had to install the core files instead of the module itself after reading the doc http://doc.silverstripe.com/modules:swfuploadfield

See if you can make
http://www.silverstripe.org/swfuploadfield-module/

stand out like dogs balls hehe...

Avatar
TF-35Lightning

Community Member, 137 Posts

29 April 2010 at 8:36pm

Hi uncle cheese yes I ran the same gauntlet as suntrop and thought i had to install the core files instead of the module itself after reading the doc http://doc.silverstripe.com/modules:swfuploadfield

See if you can make
http://www.silverstripe.org/swfuploadfield-module/

stand out like dogs balls hehe...