Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing ImageGallery: which Version?


Reply

6 Posts   699 Views

Avatar
m3d

20 July 2010 at 8:30pm Community Member, 8 Posts

hi there, I am quite new to SS and try to get into it...

Now I installed SWFUpload, DataObjectManager and the ImageGallery. When I create a new Site and I then click on it in SiteTree in Admin, I get the following error: Error: DataObjectManager requires the SWFUpload module.

Well, swfupload is installed...

I had the same problem on another computer and tried different versions. well, in the end it was working - with some bugs, but I could test it at least. But I cannot remember which version of which module I have installed.

So I want to ask: which Version should I install? Which Version of SWFUpload, of DataManagerObject and ImageGallery?

Thanks for any suggestions or help with this error.
nina

Avatar
UncleCheese

21 July 2010 at 1:57am 4085 Posts

All that should matter is that the class SWFUploadField exists. I don't think it's version dependent.

You got this? http://www.silverstripe.org/swfuploadfield-module/

Avatar
ShaneLumos

21 July 2010 at 4:00am Community Member, 11 Posts

I am new with silverstripe and this is the problem I am having

my issue: my images aren't showing up on my portfolio page. It only has one album, so it should just show the images, correct? The images have uploaded successfully and show up in the CMS, under the "Photos" tab, but nothing is getting converted to content on the rendered page.

This is on my own theme that I created from scratch and it doesn't have an ImageGalleryPage template it is just a stand page layout

Silverstripe 2.4.0
DOM r403
SWFUplad r401
ImageGallery r404

Avatar
UncleCheese

21 July 2010 at 4:16am 4085 Posts

Do you have a link?

Avatar
ShaneLumos

21 July 2010 at 4:46am Community Member, 11 Posts

this is the link to my website page
[url=http://www.lumoswebdesign.com.au/portfolio/] this is the page [/url]

Avatar
m3d

23 July 2010 at 8:16pm Community Member, 8 Posts

thanks, with the download you suggested it works!