Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

'HTTP Error' Uploading Documents using FileDataObjectManager


Reply

46 Posts   7101 Views

Avatar
VRoxane

24 November 2010 at 2:19am Community Member, 42 Posts

Hi guys !

I have exactly the same error Ryan. When SWF Uploader stopped working, I changed to Uploadify.
But the problem is not the module we use for uploading files.

Everything worked perfectly few days ago. It stopped working on localhost as well, on all browsers I have tried (FF, IE, Opera and Safari) so it's not a browser or a server problem.

A friend thinks there's a problem with Flash. I really think it's possible. Any ideas ?

Avatar
UncleCheese

24 November 2010 at 5:26am 4085 Posts

It's a PHP error of some sort. Turn on UploadifyField::show_debug(); and that show alert the error out.

---------------
Silverstripe tips, tutorials, screencasts, and more. http://www.leftandmain.com

Avatar
VRoxane

24 November 2010 at 5:45am Community Member, 42 Posts

This is what is shown with the debug on :
(Nothing changes when the HTTP Error occurs ...)

script: %2Fadmin%2FEditForm%2Ffield%2FPhotos%2FUploadifyForm%2Ffield%2FUploadedFiles%2Fupload
refreshlink: /admin/EditForm/field/Photos/UploadifyForm/field/UploadedFiles/refresh?ctf[Photos][start]=0&ctf[Photos][per_page]=10&ctf[Photos][showall]=0&ctf[Photos][sort]=&ctf[Photos][sort_dir]=&ctf[Photos][search]=&ctf[Photos][filter]=&ctf[Photos][view]=grid&ctf[Photos][imagesize]=100
uploader: /uploadify/javascript/uploadify.swf
scriptAccess: sameDomain
queueSizeLimit: 40
auto: 1
fileExt: *.jpg;*.JPG;*.jpeg;*.JPEG;*.gif;*.GIF;*.png;*.PNG;*.jpg;*.JPG;*.jpeg;*.JPEG;*.gif;*.GIF;*.png;*.PNG
fileDesc: Images
cancelImg: /uploadify/images/cancel.png
image_class: Image
file_class: File
buttonText: Upload files
queueID: UploadifyFieldQueue_UploadedFiles
wmode: transparent
hideButton: 1
upload_on_submit:
sortable:
sizeLimit: 67108864
multi: 1
scriptData:

Avatar
UncleCheese

24 November 2010 at 6:17am 4085 Posts

Is your server configured to display PHP errors? Is your environment in dev mode?

Avatar
VRoxane

24 November 2010 at 7:06am (Last edited: 24 November 2010 7:06am), Community Member, 42 Posts

Sorry I'm not familiar with debugging... :/
Now in dev mode with errors sent to my mailbox, i see nothing more (and didn't receive any mail)

Director::set_environment_type("dev");
UploadifyField::show_debug();
Debug::send_errors_to("me@thesite.com");

Can you tell me more about "Is your server configured to display PHP errors?" ?

Avatar
UncleCheese

24 November 2010 at 8:18am 4085 Posts

Make sure display_errors is on in your php.ini..

---------------
Silverstripe tips, tutorials, screencasts, and more. http://www.leftandmain.com

Avatar
bradt

25 November 2010 at 3:44am Community Member, 5 Posts

I'm having a very similar issue as VRoxane. I'm getting the 'HTTP Error' message and no error output with Director::set_environment_type('dev'), UploadifyField::show_debug(), and PHP error reporting on (http://www.beehiveholdings.com/test.php).

I've used Wireshark to see what's going on and it looks like the authentication is failing. Here's the Wireshark captured HTTP response:

No. Time Source Destination Protocol Info
46 4.612543 65.61.167.253 192.168.10.102 HTTP HTTP/1.1 302 OK

HTTP/1.1 302 OK\r\n
[Expert Info (Chat/Sequence): HTTP/1.1 302 OK\r\n]
[Message: HTTP/1.1 302 OK\r\n]
[Severity level: Chat]
[Group: Sequence]
Request Version: HTTP/1.1
Response Code: 302
Server: Apache/2.2\r\n
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0\r\n
Content-Type: text/html; charset="utf-8"\r\n
Date: Wed, 24 Nov 2010 13:50:53 GMT\r\n
Location: /Security/login?BackURL=%2Fadmin%2FEditForm%2Ffield%2FPhotos%2FUploadifyForm%2Ffield%2FUploadedFiles%2Fupload\r\n
Expires: Thu, 19 Nov 1981 08:52:00 GMT\r\n
Pragma: no-cache\r\n
Connection: close\r\n
Set-Cookie: PHPSESSID=c9g0479dulj1geq2mrm9vdp4a2; path=/\r\n
Set-Cookie: X-Mapping-caklakng=83E218561EE0F725E5A6FFEA755DEB33; path=/\r\n
Content-Length: 0\r\n
[Content length: 0]
\r\n

Avatar
UncleCheese

25 November 2010 at 8:38am 4085 Posts

302 redirect.. looks like an authentication error to me?

---------------
Silverstripe tips, tutorials, screencasts, and more. http://www.leftandmain.com