Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Upgrade SS + DOM issues [SOLVED]


Reply

7 Posts   858 Views

Avatar
chinaski

22 November 2010 at 7:43am Community Member, 26 Posts

I'm attempting to upgrade a site from 2.4 to 2.4.3. The site relies on DOM (installed rev. 396).

I have copied the production site to a local instance and did the upgrade from 2.4 to 2.4.3. The first issue that comes up is that I'm getting a $(".DataObjectManager").livequery is not a function in the js console and the add image button opens a new window rather than the thickboxy popup that it was doing previously.

I saw a post in this forum indicating this error arose because of a dependency change, and that it was fixed in the DOM trunk. So I updated the DOM to the revision available on this site (rev. 515), and now the popup works but I am unable to add images. The uploader indicator just sits there showing "processing" in the box and never does anything else. When I close the popup no image has been uploaded.

I'm not seeing errors in the logfile.

I'm obviously postponing the upgrade to 2.4.3 until I can resolve these issues. Help is appreciated.

Avatar
lerni

22 November 2010 at 9:17pm (Last edited: 22 November 2010 9:18pm), Community Member, 80 Posts

hi

just to check it out. remove/rename/turn-off the .htaccess in assets and try it again.

Avatar
UncleCheese

23 November 2010 at 3:46am 4085 Posts

Try getting rid of SWFUpload and using the Uploadify module. http://www.leftandmain.com/silverstripe-modules/2010/08/26/uploadify/

--------------------
SilverStripe tips, tutorials, screencasts and more: http://www.leftandmain.com

Avatar
lerni

23 November 2010 at 4:26am Community Member, 80 Posts

in my case it was not related to DOM nor CTF. not shure if it's the same in your case ???

since 2.4.3 .htaccess in assets changed and if it's there in it's current form, my hosters servers stops serving stuff from assets.

Avatar
chinaski

23 November 2010 at 7:09am Community Member, 26 Posts

I have renamed the .htaccess file in assets, to no effect.

I will try the uploadify module and see if that works.

Thanks for the replies...

Avatar
chinaski

23 November 2010 at 7:33am Community Member, 26 Posts

Uploadify seems to be the shiz - worked straight away when I dropped it into the www folder. I will run with that, although it means I have to document and retrain the users who have grown used to the "old" interface.

Thanks for the assistance Uncle Cheese and your awesome plugins.

Avatar
dacar

24 November 2010 at 1:31pm Community Member, 168 Posts

Hi, i have got the same problem with the .htaccess file after the upgrade to 2.4.3. Only if i delete the .htaccess, i can access files from assets.

Greetings, Carsten.