Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Uploadify HTTP Error


Reply


80 Posts   22658 Views

Avatar
joelg

Community Member, 129 Posts

8 February 2011 at 8:14pm

Hi UncleCheese

I have another problem with DataObjectManager and Uploadify at one of my shared servers. When I upload with uploadify or swfupload the upload process begins and it reaches 100%. However after this point, an http error shows up and I get kicked out of SilverStripe. The file never gets copied nor written to the database. I have to login again to enter the CMS.

Charles doesn't help me much. The upload process returns a 200 response. No 401 or 500 errors as far as I can see. I've set folder permissions on assets to 755, even tried with 777, didn't help either. When I place die("Hello") in the upload function in UploadifyField.php nothing really happens. Same error.

What am I doing wrong?

Joel

Avatar
Viv

Community Member, 30 Posts

10 February 2011 at 5:20pm

That's basically the same as I am getting. Just tried a different server setup with a different host and still getting the same happening. Sometimes I will be logged out and have to log in again and other times after hitting 'continue' I get the message 'Security token doesn't match, possible CSRF attack'.

At my fresh installation screen for SS 2.4.5, I get the warning:

"magic_quotes_gpc is set to '1' in php.ini. This should be turned off, as it can cause issues with cookies. More specifically, unserializing data stored in cookies."

Does the 'Security Token' make use of cookies - in which case correcting this setting would potentially fix the problem? I'm also in shared server situation, so not sure if will be able to get this changed. I might be totally off-track with this but thought I should make the post.

Avatar
joelg

Community Member, 129 Posts

10 February 2011 at 10:49pm

Hi Viv

Thanks for your feedback. It seems that magic_quotes_gpc is actually set to On. However, inserting ini_set ('magic_quotes_gpc', 0); into _config.php doesn't solve the problem. I'm still getting logged out of SilverStripe. Doing a packet sniff with charles still gives me a 302 response:

HTTP/1.1 302 OK
Date: Thu, 10 Feb 2011 09:42:57 GMT
Server: Apache/2.2.9 (Debian)
X-Powered-By: PHP/5.2.14-0.dotdeb.0
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Set-Cookie: PHPSESSID=3317f5592fa9e2c515e48d68f034881b; path=/; HttpOnly
Location: /Security/login?BackURL=%2Fadmin%2FEditForm%2Ffield%2FGalleryImages%2FUploadifyForm%2Ffield%2FUploadedFiles%2Fupload%3FSecurityID%3D2aec70e49eed579e26e361697ba354c62f94dfb0%26ctf%5BGalleryImages%5D%5Bstart%5D%3D0%26ctf%5BGalleryImages%5D%5Bper_page%5D%3D10%26ctf%5BGalleryImages%5D%5Bshowall%5D%3D0%26ctf%5BGalleryImages%5D%5Bsort%5D%3DSortOrder%26ctf%5BGalleryImages%5D%5Bsort_dir%5D%3D%26ctf%5BGalleryImages%5D%5Bsearch%5D%3D%26ctf%5BGalleryImages%5D%5Bfilter%5D%3D%26ctf%5BGalleryImages%5D%5Bview%5D%3D
Vary: Accept-Encoding
Content-Length: 0
Connection: close
Content-Type: text/html; charset="utf-8"

Should I contact my hosting provider and ask them to turn magic quotes to off in php.ini? What do you suggest?

Thanks again for your help.

Joel

Avatar
spankmaster79

Community Member, 46 Posts

11 February 2011 at 2:19am

I've tried to eliminate the 401 Error by disabling the Basic Authentification of the Webroot and now I've even tried to disable mod_security in Apache over .htaccess by using:

SecFilterEngine Off
OR, to disable HTTP POST scanning only, use the following instead:
SecFilterScanPOST Off

But then the webserver responds with a 500.....

Any clue what to test...

Avatar
UncleCheese

4085 Posts

11 February 2011 at 4:09am

What is the content of the 500 response?

Avatar
ccburns

Community Member, 74 Posts

12 February 2011 at 4:56pm

I am getting the same error on upload. I have dataobject_manager and uploadify on two sites on the exact same server and only one of the sites has a problem.

This is the response I am getting from the upload using Charles

HTTP/1.1 302 OK
Date: Sat, 12 Feb 2011 03:28:37 GMT
Server: Apache
Set-Cookie: PHPSESSID=29eu45cot6s5taqju42lm6ftv1; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Set-Cookie: PHPSESSID=1dl4u8chjcobjvlu15fjprqff7; path=/
Set-Cookie: alc_enc=deleted; expires=Fri, 12-Feb-2010 03:28:45 GMT; path=/
Set-Cookie: alc_enc=deleted; expires=Fri, 12-Feb-2010 03:28:45 GMT
Location: /Security/login?BackURL=%2Fadmin%2Fassets%2FEditForm%2Ffield%2FFiles%2FUploadifyForm%2Ffield%2FUploadedFiles%2Fupload
Vary: Accept-Encoding
Content-Length: 0
Connection: close
Content-Type: text/html; charset="utf-8"

I don't know if that helps work out the problem at all. I am currently copying those two modules over from the site that works to the site that doesn't work to see if that will help... I'll let you know.

Colin

Avatar
ccburns

Community Member, 74 Posts

12 February 2011 at 5:18pm

Nope, I copied the code over and no luck!!!

Avatar
UncleCheese

4085 Posts

12 February 2011 at 5:44pm

Are you using Rackspace cloud hosting?