Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

ImageGallery: 'Fatal error: Class 'ImageUploadField' not found'


Reply


4 Posts   1471 Views

Avatar
extasey

Community Member, 14 Posts

13 February 2011 at 9:34pm

Hi,

Sorry if this question has been asked before, I'm quite new to the website and am having trouble navigating/searching the site.

I am using SilverStripe CMS 2.4.5 and have both the dependencies (SWFUploadField and DataObjectManager) installed for this module and when I create a new page it looks like this:

With the error:
Fatal error: Class 'ImageUploadField' not found in /home/lovecak2/public_html/gallery/code/ImageGalleryAlbum.php on line 27

Is this a know/fixed issue? Or an 1D10T error?
If any more information is required just tell let me know.

Any help appreciated!

Avatar
extasey

Community Member, 14 Posts

13 February 2011 at 9:54pm

Sorry, don't know why the image is a little screwy.
Heres a full shot of the screen:
http://image-host.com/images/56ztoanvsn1r0vuvbl3.png

Avatar
UncleCheese

4085 Posts

14 February 2011 at 5:41am

Make sure you have Uploadify installed. http://www.leftandmain.com/silverstripe-modules/2010/08/26/uploadify/

Avatar
extasey

Community Member, 14 Posts

14 February 2011 at 5:54pm

Ahh fantastic!
Thank you so much, solved the problem!