Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

File Size Error when i try to upload 2mb txt file


Reply

5 Posts   3138 Views

Avatar
te_chris

16 February 2011 at 11:00am Community Member, 24 Posts

Hey,

I'm getting this error when i try to use DOM with Uploadify to upload a 2.36mb txt file. I tried using UploadifyField::setVar to change the file size limit but that didn't seem to work either. Any ideas?

also on an easier note, I'm displaying these files to the frontend, what's the attribute to get the image that is specific to the filetype? (i.e pdf icon for pdf, word icon for word, excel for excel etc).

Thanks!

Avatar
te_chris

18 February 2011 at 9:27am Community Member, 24 Posts

Is anyone able to help me with this? I really need to find a solution to this problem

Avatar
figjam

25 April 2011 at 3:54pm (Last edited: 15 January 2013 1:40pm), Community Member, 10 Posts

This may be because your PHP "upload_max_file_size" defaults to 2M.

Try increasing it e.g. by putting a "php.ini" file in your sapphire directory:

upload_max_filesize = 8M

Worked for me! :-)

* If you need something larger e.g. 16M, also add: post_max_size = 16M
* You may require a page refresh after adding sapphire/php.ini

ADDITIONAL:
* If using SS3 you need to put php.ini in your "framework" directory
* If you want to put your php.ini in your home directory, you may need to fiddle with your .htaccess - see [url=http://www.silverstripe.org/general-questions/show/16355]Fixing memory size[/url] post

Avatar
Terminator4

9 November 2011 at 8:20am Community Member, 81 Posts

I tried that and unfortunately I had no luck with it.

Any other thoughts?

Avatar
neilcreagh

2 December 2011 at 3:57am Community Member, 94 Posts

I just had the same problem so I added this to my .htaccess file in the root of the site and it fixed it:

php_value post_max_size 20M
php_value upload_max_filesize 20M