Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Hit and miss with Uploadify - IO Error


Reply

8 Posts   5479 Views

Avatar
Ryan M.

25 March 2011 at 2:22pm Community Member, 309 Posts

The files I upload through Uploadify are hit and miss.. Some complete successfully, while others light up in red and display a message, "IO Error". There doesn't seem to be a particular pattern to which files this happens to. Anybody have any idea what's up with that?

Avatar
Ryan M.

26 March 2011 at 11:19pm Community Member, 309 Posts

Update, I figured out it was only occurring on ImageUploadFields while I selected multiple images. ImageUploadFields are supposed to only accept a single file, while the Multiple....UploadFields are meant for multiple objects. I guess the question now is why doesn't the upload field prevent you from selecting multiple files, or at least gives a more specific error than an "IO Error" message?

Avatar
Kowalski

18 April 2011 at 11:50am Community Member, 2 Posts

Ryan; can you describe in a bit more detail what you did?
I have the same problem with Uploadify... Random IO errors on multiple uploads. Some get trandferred, others don't. But no clear pattern...

Avatar
Ryan M.

18 April 2011 at 12:34pm Community Member, 309 Posts

Well, I tried selecting a single file and uploading that, it went through fine. Then I tried selecting multiple files, and while the upload form accepted them without a protest, some images would fail the upload. This was tested on an ImageUploadField, which is supposed to handle only one image file.

Avatar
Kowalski

19 April 2011 at 8:17am Community Member, 2 Posts

Ok, thanks. I thought I had the latest Flash plugin installed (Safari browser, MacOS X 10.6.7), but an update to to the most recent version of the plugin have solved the problem for me.

Avatar
Ryan M.

19 April 2011 at 10:51am Community Member, 309 Posts

If the Flash version is breaking Uploadify, then UncleCheese needs to be aware of this and fix it for backwards compatibility.

Avatar
elgordo

24 April 2011 at 7:30pm Community Member, 70 Posts

I think the problem is with the jquery uploadify widget being Flash sensitive - I've been bashing my head trying to figure out why it suddenly stopped working then discovered the Flash version problem. Working on one computer but not the other... :(

Avatar
DsX

2 March 2013 at 6:00am Community Member, 178 Posts

I have had an on going IO error problem of months. Can figure it out.
All upload forms, (as part of Uncle cheeses gallery module, via the Files & Images section etc..)
The only way I can seem to upload an image is via the Pixlr module.. it is work perfectly.

Investigating I found that any new folder I create with the Files & Folders 'create' feature, is set 755, and for some reason I am unable to upload to it via FTPs unless set to 777.. so I do that. Now I can upload images via FTPs, but not via the CMS.
Still IO error. (except with Pixlr)

Could I perhaps have a user/group problem on my server? That might explain why my FTPs login can't upload unless dir is set 777.

What user is the CMS trying to act as? How can I check? Anyway to check what the Pixlr module is running as?
Any other guidance??? Any way to reset the vhost directory to defaults?