Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Uploadify doesn't attach the file


Reply

6 Posts   956 Views

Avatar
moonchild100

20 May 2011 at 6:37am (Last edited: 20 May 2011 11:40am), Community Member, 18 Posts

Hi UC,

I'm new to Silverstripe, the uploadify module can upload the file to the folder but cannot attach it. I can see your uploaded file is in the
right folder, and I can attach it afterwards, but it fails to attach the file at the time you upload it.

It seems many others has the same question, I already add the code ContentNegotiator::disable(); to the uploadify/config.php and <IfModule mod_security.c>
SecFilterEngine Off
</IfModule>
to mysite/.htaccess

but none of them solve the problem....

many thanks

Avatar
UncleCheese

20 May 2011 at 5:39pm 4085 Posts

Make sure the folder name is dataobject_manager

Avatar
moonchild100

20 May 2011 at 5:53pm (Last edited: 20 May 2011 5:56pm), Community Member, 18 Posts

I had the name of for "dataobject_manager". I think I exact issue with the thread here

[url]http://silverstripe.org/dataobjectmanager-module-forum/show/16338[/url] and

http://silverstripe.org/dataobjectmanager-module-forum/show/15893

there are other thread discuss the same issue, seems a common problem? but i didn't see a solution...help please

Avatar
moonchild100

21 May 2011 at 10:44am Community Member, 18 Posts

I tried to install the silverstripe all over again on a mac local, and the uploadify works great.

Then I uninstalled the SS on the server and using the MAC to install the SS on the server again, and uploadify works fine too.....

who can explain this ??? too weird......

now i wonder if the other people who had the same issue were working on Windows?

Avatar
VRoxane

26 May 2011 at 4:03am Community Member, 42 Posts

I got the same error Moonchild, there's a problem with the "refresh" function. It doesn't launches. I think it has something to do with the hosting...

Avatar
moonchild100

26 May 2011 at 5:05am Community Member, 18 Posts

Well, i already give it up...For my case, uninstalling the whole SS on the sever, and using MAC to install it again works....don't know why....

also works for local, e.g it has the same issue when i use it on my PC local machine, but everything's fine with if I use MAMP on the Mac Local... weird huh?