Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Broken Resource Tab?


Reply

4 Posts   852 Views

Avatar
mirakelsey

13 June 2011 at 2:22pm Community Member, 9 Posts

I'm not sure how, but the resource tab for the site I'm working on seems to have a bunch of broken links within it. Here's a screencap to show exactly what I'm dealing with: http://i768.photobucket.com/albums/xx328/mirakelsey/resourcesnapshot.png

I just need to be able to upload pdfs. I'm just not sure where in the code this seems to be breaking.

Avatar
UncleCheese

14 June 2011 at 2:11am 4085 Posts

Make sure the name of the directory is "dataobject_manager"

--------------------
SilverStripe tips, tutorials, screencasts and more: http://www.leftandmain.com

Avatar
mirakelsey

7 July 2011 at 10:39am Community Member, 9 Posts

Sorry to bring this up again but that problem has revived itself.

That fix worked on my test server. But now I've installed Silverstripe on my webhost (Siteground) and gotten the entire site up and running perfectly, except for the fact that this resource page has all its links broken again.

The folder is properly named. What's wrong now?

Avatar
UncleCheese

8 July 2011 at 8:50am 4085 Posts

If the folder is properly named then you have some sort of pathing issue. This problem occurs when the necessary assets (CSS, JS, images) are 404ing.

As a test, make sure you can access http://yoursite.com/dataobject_manager/javascript/dataobject_manager.js from your browser.

--------------------
SilverStripe tips, tutorials, screencasts and more: http://www.leftandmain.com