Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Uploadify problem


Reply


5 Posts   895 Views

Avatar
Xazen

Community Member, 18 Posts

20 November 2011 at 4:49am

Edited: 21/11/2011 3:16am

When I try to add a FileUploadField to my backend. But it seems to has some problems. I tried it in FF8.0 and Chrome

class Home extends Page {
   static $icon = "themes/luckychocolate/images/treeicons/home";
   
   static $db = array();
   
   static $has_one = array(
      'TestFile' => 'File'
   );
   
   function getCMSFields(){
      $fields = parent::getCMSFields();
      $fields->addFieldToTab('Root.Content.File', new FileUploadField('TestFile', 'Upload a file'));       
      return $fields;
   }
}

That's how the field looks like:
Chrome:
[URL=http://imageshack.us/photo/my-images/838/chromed.png/][/URL]

FireFox:
[URL=http://imageshack.us/photo/my-images/408/uploadifyff8.png/][/URL]

If I click on the tabs, nothing seems to happen. After choosing a file, the filename will be displayed next to the Browse-button and nothing happends. In the "File & Images" section the form looks the same.

Avatar
UncleCheese

Forum Moderator, 4096 Posts

21 November 2011 at 5:55am

Looks like you have a Javascript error somewhere. Check the console.

---------------
Silverstripe tips, tutorials, screencasts, and more. http://www.leftandmain.com

Avatar
AndrewNZ

Community Member, 1 Post

19 January 2012 at 2:39pm

Hi Xazen,

Did you figure this out? We are having a similar problem. We installed DataObjectManager and Uploadify and ever since then, when we try to upload files (even from the standard Files & Images tab in the admin mode, we can select a file exactly like you but then nothing happens and no files get uploaded.

Thanks

Andrew

Avatar
wvujeb

Community Member, 1 Post

24 April 2012 at 6:15pm

I'm having this same problem with the Files & Images tab. I've checked the console, but I'm not seeing any errors. Does anybody have suggestions on where else to check?

Avatar
coffeespoon

Community Member, 8 Posts

23 May 2012 at 9:39am

Hallo guys,

I found the same issue. The solution was very easy. Change the folder's name from Uploadify to uploadify.
http://www.silverstripe.org/dataobjectmanager-module-forum/show/16793

Cheers