Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

$VideoPopup not working but $Player is (Solved)


Reply

3 Posts   531 Views

Avatar
stevanovich

3 December 2011 at 12:28am Community Member, 60 Posts

Okay so I have done all the hard work go ffmpeg working, sorted the videothumbnails out, and permissions etc phew....the last hurdle is this when changing the code to $VideoPopup(100x100,400x300) the thumbnail is there but when clicked the popup appears but says movie not loaded in flash. When I revert to code $Player (400,300) it plays so it is not the movie. Anyone had this issue before with videopopup??

Avatar
kingko

6 December 2011 at 2:06pm Community Member, 1 Post

I met this problem before. My reason of this problem was popup window could not load the 'player.swf'. And I found that Director::absoluteURL('dataobject_manager/code/flv/shadowbox/libraries/mediaplayer/player.swf'); is wrong in FLV.php. Just copy player.swf to 'dataobject_manager/code/flv/shadowbox/libraries/mediaplayer/" this folder. This problem was fixex.

Hope this can help.

Avatar
stevanovich

9 December 2011 at 10:36am Community Member, 60 Posts

Excellent kingo just the trick...why it has the wrong path I don't know anyway it worked.... Only one more issue which is why flv files crash with getimagesize error on gd.php. Ahhh why is it not easy?