Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Preview: DataObjectManager module


Go to End
Reply


379 Posts   62738 Views

Avatar
UncleCheese

Forum Moderator, 4094 Posts

26 April 2009 at 1:52pm

@drye - I think since SimpleTreeDropdownField is an subclass of DropdownField, you should be able to just do $field->setEmptyString('Foo');

Avatar
martimiz

Forum Moderator, 1106 Posts

28 April 2009 at 3:37am

Hi UncleCheese,

I'm trying out dataObjectManager r133 - and I love it! Now I wanted to do some translation. Could it be that the (en_US) language file is empty? I could try and translate the german version, but if you still got it hanging 'round somewhere...

Avatar
UncleCheese

Forum Moderator, 4094 Posts

28 April 2009 at 3:54am

There should be a deDE3.php file in the lang folder, no? Not sure what happened to the en_US file. I've replaced it. Do an SVN update.

Avatar
Johnny

Community Member, 34 Posts

29 April 2009 at 4:52am

Hi UncleCheeze!!

The error happens at line 513:

509: $file->write();
511: $obj->$idxfield = $file->ID;
512: //die ("lowerbound");
513: $ownerID = $_POST['parentIDName'];
514: die ("upperbound");
515: $obj->$ownerID = $_POST['controllerID'];

It's wierd no?

Hope this will help!

JP

Avatar
UncleCheese

Forum Moderator, 4094 Posts

29 April 2009 at 5:47am

Are you sure you're on the latest SVN of dataobject_manager and swfupload? That looks like a bug I resolved a while ago.

Avatar
Johnny

Community Member, 34 Posts

29 April 2009 at 3:02pm

Hi UncleCheeze!

I updated from SVN and it still happening!

JP

Avatar
pali

Community Member, 33 Posts

29 April 2009 at 9:42pm

hello,

im new in SS and i feel stupid in fundamental things :(

i added many images into a page, i know how to call them in page.ss. But i need to show only 1st image on pagelist.ss ->

im using

<% if ImageAtts %>
<% control ImageAtts %>
<% if First %>
<a href="$Link" title="$Title">$ImageAtt.SetWidth(176)</a>
<% end_if %>
<% end_control %>
<% end_if %>


.. and it outputs only empty anchor.

if i remove <% if First %> all images are shown.

thanky

pali

Avatar
schellmax

Community Member, 126 Posts

30 April 2009 at 1:21am

@pali:
your posted code should work, tried it in 2.3.1
could you post your corresponding page class/controller code?

@UncleCheese:
found another inconsistency, not sure though wheter this one is dataobjectmanger - related:
whenever i duplicate a page in cms, all related dataobjects (managed in a dataobjectmanager) are gone for the duplicate.
haven't checked using a regular ctf, so might be a silverstripe-problem?

btw: considerable feedback (317 posts by now!) to this module makes clear it requires it's own forum. should i send an email to silverstripe-staff?

Go to Top