Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Bug Reports


Go to End
Reply


297 Posts   52405 Views

Avatar
banal

Community Member, 901 Posts

26 January 2010 at 12:27am

Hello Uncle Cheese

Here's another patch for the current release of the DOM (Rev 347).
There seems to be missing a closing DIV in the RelationDataObjectManager template. When using a RelationDataObjectManager instance in the CMS, all following tabs get messed up (eg. they appear blank).

Patch is here: http://bummzack.ch/misc/RelationDataObjectManager.patch

Avatar
JoshuaLewis

Community Member, 76 Posts

1 February 2010 at 4:55am

I believe I'm experiencing a similar bug as banal. I'm using a recent update to SS 2.3.5 and DOM r355.

After some trial and error I got the tabs to display correctly by adding an additional div to the end of RelationDataObjectManager.ss. This makes for two div's following $ExtraData at line 110 instead of just one.

Avatar
Zauberfisch

Community Member, 30 Posts

3 February 2010 at 12:29am

Edited: 03/02/2010 12:29am

the if you use SimpleHTMLEditorField in a nested data object manager it is not as big as the popup (see screen)

[url]http://www.imagebanana.com/view/e26c9s8/textfield_to_small.png[/url]
alternativ url: [url]http://yfrog.com/jntextfieldtosmallp[/url]

greetings zauberfisch

Avatar
theAlien

Community Member, 131 Posts

8 February 2010 at 1:42pm

Hi,

It seems the gridview of ManyManyFileDataObjectManager doesn't display any icons (for testing purposes I also tried FileDataObjectManager, and in that case, the icons are displayed just right).

I'm on revision 359. Debugging doesn't return any errors.

Avatar
socks

Community Member, 190 Posts

9 February 2010 at 10:55pm

Edited: 10/02/2010 7:53am

SS 2.3.5
DOM r359

When I click on an image thumbnail in the CMS to edit, I get a mess of scroll bars.

Screenshot:
http://drop.io/sfc6mgw/asset/picture-28-png

Thank you

--------------

EDIT:

Wow, you're super quick with these updates. I figured I had the latest since I downloaded it not that long ago. Updated to r366, all is well.

Thanks again!

Avatar
UncleCheese

Forum Moderator, 4096 Posts

10 February 2010 at 3:02am

Update to r366.

Avatar
-p>

Community Member, 1 Post

10 February 2010 at 1:01pm

Hi UncleCheese, and thanks for the great module!

I got an problem with DOM (r366) and latest SS2.4beta1 release. Datepickerfield didn't work properly ( pop-up appeared, but clicking the date did nothing). Firebug's diagnose was "jQuery.datepicker is undefined".

I updated the line 69 from
Requirements::javascript($this->BaseHref() . "dataobject_manager/javascript/jquery-ui-1.6.js");
to
Requirements::javascript($this->BaseHref() . "dataobject_manager/javascript/jquery-ui.1.7.js");

and it fixed the datepicker field. Not yet sure, if I messed something else up, but I hope this helps somebody with similar problems. Maybe this could be fixed in svn also?

Avatar
UncleCheese

Forum Moderator, 4096 Posts

10 February 2010 at 3:21pm

Yeah, DOM isn't ready for 2.4 yet. There's a whole bunch of changes that have to be made especially in regards to javascript dependencies.

Go to Top