Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Bug Reports


Go to End
Reply


297 Posts   52943 Views

Avatar
Carbon Crayon

Community Member, 598 Posts

25 February 2010 at 5:01am

For reference the patch is here: [url]http://open.silverstripe.org/ticket/3938[/url]

not sure why it hasnt made it's way into the core yet....

Avatar
joshy

Community Member, 57 Posts

25 February 2010 at 5:05am

Thanks, Aram.

Avatar
wmk

Community Member, 46 Posts

25 February 2010 at 5:31am

Aram, i guess because noone made a real patch :(

Avatar
ImacSS

Community Member, 35 Posts

4 March 2010 at 7:27am

First off, if I haven't already stated it - just wanted to thank you on the herculean effort of creating and maintaining this fantastic module. I have already constructed 2 comprehensive websites with SilverStripe, which would have been considerably more difficult had it not been for the DataObjectManager module.

My issue is that I am trying to setup a forward/public facing form which contains both a SimpleWysiwygField and a DatePicker field. However, it appears that when I include a SimpleWysiwygField, the functionality of the DatePicker field becomes broken in the following manner.

When I click into the DatePicker field, the calendar does pop up. However, when I try to click on the next/previous month controls, or select a day I recieve the 'jQuery.datepicker' is not a function.

I am including a more recent version of jQuery for other purposes (1.3.2) on the main Page.ss template. If I comment out the Requirements line for 'jquery.js' in the SimpleWysiwygField.php file, then the DatePicker object works once again, but the SimpleWysiwygField just renders as a standard textbox.

I realize that this setup is probably not something that you ever intended to have working together, but just curious if you might be able to point me in the right direction to try and get these two controls to play nice with each other in a forward/public facing scenario.

As I can just simply replace the SimpleWysiwyg control with a standard textbox, this issue is obviously not a show-stopper, but would be nice if I could get resolved.

Thanks once again for all of your hard work on one of the most useful SilverStripe modules.

Versions working with:
SilverStripe: 2.3.3
DataObjectManager: R333
EventCalendar: R83
SWFUpload: R271

Avatar
Pranil

Community Member, 17 Posts

9 March 2010 at 10:06pm

I'm not sure if this is the right place to be posting this, but here goes anyways. Got a site running in Silverstripe 2.3.4, with a custom page type that has projects and photos using the DOM. Everything works fine, only thing is in the backend, whenever we upload a new image or go to view and existing one, the iframe that pops up doesn't have the width set correctly. Looking at the code using firebug shows the iframe width isn't being set. Have linked to screenie, cheers. [url]http://www.dropbox.com/gallery/3310912/1/errors?h=67777a[/url]

Avatar
UncleCheese

Forum Moderator, 4096 Posts

10 March 2010 at 3:02am

That bug was fixed several revs ago. Make sure you're running the latest version.

Avatar
Pranil

Community Member, 17 Posts

10 March 2010 at 9:20am

Sorry latest version of SS or latest version of DOM?

Avatar
UncleCheese

Forum Moderator, 4096 Posts

10 March 2010 at 9:36am

Latest version of DOM. Should be r375..

Go to Top