Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Bug Reports


Reply

297 Posts   49785 Views

Avatar
MarcusDalgren

21 April 2010 at 3:06am Community Member, 288 Posts

Hi UncleCheese!

I'm getting a validation error from the CMS when using the datepicker field in the CMS. Since there's been alot of changes to how the date fields work it isn't that surprising that this would start to fail, is there any fix on the horizon?

I've been mucking about abit but I'm not sure exactly what SS wants back from us right now.

Avatar
micahsheets

23 April 2010 at 9:19am Community Member, 165 Posts

I am having an issue with SS 2.3.7 and Image Gallery 2.3 branch. I have an Image Gallery Page with two Albums. I have done some debugging and found that Albums.MoreThanOnePage is using the Images Per Gallery limit as the Albums Paging limit as well. The result is that unless I have more than 16 Albums I don't get Album Pagination. Image Pagination within a gallery works fine also using the 16 limit.

Avatar
joshy

12 May 2010 at 9:31pm Community Member, 57 Posts

Hi UncleCheese,

On trunk (r 386), SimpleTreeDropdownField doesn't seem to be working.

I have as $has_one for LinkPage => Page, and when I do this:

new SimpleTreeDropdownField("LinkPageID", "Choose a page to link to", "Page")

The field simply doesn't show.

When I change LinkPageID to 'LinkPage', the field shows but the value does not store. I have used this exact code elsewhere and it worked fine!

Could you please take a look?

Cheers,

Josh

Avatar
UncleCheese

13 May 2010 at 1:31am 4085 Posts

That means the field has already been added to your form from another source. A lot of times that happens with legacy fieldnames, so it's really common with something like SimpleTreeDropdownField because it's based on a foreign key. You just have to get them cleaned up. As an experiment, just look at the source of your form and look for anything in there already named "LinkedPageID" (probably a hidden input). Try changing the field name to something else (even if it doesn't exist in the DB yet) and you'll see that it gets added. Usually just a namespace conflict.

Avatar
joshy

13 May 2010 at 3:44am Community Member, 57 Posts

Hi,

Thanks for your reply. I have changed it to something obscure and the issue is still present. I may be wrong but it looks like a recently introduced bug because this same code has worked on previous SS sites we've done.

Cheers,

Josh

Avatar
Johnny

15 May 2010 at 4:39am Community Member, 34 Posts

Hi!

There's a bug using DataObjectManager. Drag and drop reordering is broken. After clicking "Allow drag and drop reordering" checkbox, then I try to move lines around, and instead, the line is growing.

Reproduced with FF 3.6.3, Safari 4.0.5 and IE7.
I have SS 2.3.4 installed.

Thanks

Avatar
UncleCheese

15 May 2010 at 4:53am 4085 Posts

Are you running the 2.3 branch?

Avatar
danzzz

16 May 2010 at 8:51pm Community Member, 175 Posts

hi

I'm playing arround with SS 2.4 + dataobjectmanager.

I dont know if it's a bug ...

500//ERROR [User Error]: Uncaught Exception: Object->__call(): the method 'setbuttonaddtitle' does not exist on 'FileDataObjectManager'

or just the documentation is depraced?

setButtonAddTitle($title) The text that will appear on the Add button of the FileDataObjectManager. Defaults to PluralTitle.

... writes here:
http://doc.silverstripe.org/modules:dataobjectmanager

daniel