Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Bug Reports


Reply

297 Posts   49621 Views

Avatar
AdamJ

5 July 2010 at 2:00pm (Last edited: 5 July 2010 2:01pm), Community Member, 145 Posts

Not really sure to be honest :) Corrected it to HomePage and it still doesnt complete the upload...

Should also mention, Files and Images uploads fine.

Avatar
Mat Weir

5 July 2010 at 2:09pm Community Member, 33 Posts

@AdamJ, can I test it for you?

The reason I ask, a client of ours is having the same problem, yet it works for me. She mentioned that her Flash version has just been upgraded so I'm wondering if it's related the latest Flash version.

Avatar
AdamJ

6 July 2010 at 1:10pm Community Member, 145 Posts

@MatWeir - I'll see what I can do, but considering I can successfully upload from the Files and Images tab, I not sure that this relates to flash

Avatar
UncleCheese

6 July 2010 at 2:23pm 4085 Posts

Something's wrong with your model. Did you run a /dev/build after you made that change? Try using $myDOM->setParentClass("HomePage")

Avatar
AdamJ

6 July 2010 at 5:33pm Community Member, 145 Posts

Totally worked UC! Thanks!

Avatar
Mad_Clog

13 July 2010 at 10:17pm (Last edited: 13 July 2010 10:20pm), Community Member, 78 Posts

Bug with FileDataObjectManager and importing files (in IE), getting CSRF attack error because SecurityID was not posted.

File: code/FileDataObjectManager.php
Line: 500

Old code

$fields->push(new LiteralField("_ul","</ul"));


New code

$fields->push(new LiteralField("_ul","</ul>"));

Avatar
UncleCheese

14 July 2010 at 2:21am 4085 Posts

Nice! I've been trying to track that one down!

Avatar
redactuk

14 July 2010 at 5:50am Community Member, 117 Posts

When you edit an Album in ImageGallery and choose to Replace Cover Image, the From File Store option only ever lists folders and never any files. Surely this is a bug?