Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Bug Reports


Reply


297 Posts   51096 Views

Avatar
mdaum

Community Member, 2 Posts

11 March 2011 at 7:36am

Edited: 11/03/2011 7:39am

Well, I had the server admin chmod 777 the whole directory, and I'm still having the same issue... Any other idears?

EDIT: The pagetype change works for the draft site, and works when you view the draft site, but is not translating over to the published site.

Avatar
davidm2010

Community Member, 107 Posts

15 March 2011 at 4:31am

I have started having troubles as well. I am using 4.2.2, module 34f64c0. When a create a new image page, it doesn't show up in the CMS until I refresh the page. I have no other problems with other pages. When I refresh and change the title, I get an error saving content. If I try to change the page type, it gives me a save, be defaults back to the first page in the list and does not give me the image gallery page options.

I have removed the gallery, dropped the tables in the database, rebuilt but can't seem to get it working again. Thoughts?

DM

Avatar
davidm2010

Community Member, 107 Posts

15 March 2011 at 7:14am

OK, I am now getting the image gallery to work, but I had to use 2.4.5 and the code download from leftandmain. Now I have done something to my file and images section. When I select it, I thorws me to a site error page. I know I have screwed something up chasing the image gallery issue. Any thoughts?

Avatar
SheaDawson

Community Member, 46 Posts

15 March 2011 at 2:56pm

I'm having a problem with Image Gallery on SS 2.4.5. I've tried the latest gallery release and trunk version from git.

When uploading images, the upload works fine but after clicking continue I receive this error:

[Notice] Trying to get property of non-object
POST /admin/EditForm/field/GalleryItems/UploadifyForm?SecurityID=7dcd5a408c673ebde9afccff1276a527c2076180&ctf[GalleryItems][start]=0&ctf[GalleryItems][per_page]=10&ctf[GalleryItems][showall]=0&ctf[GalleryItems][sort]=SortOrder&ctf[GalleryItems][sort_dir]=&ctf[GalleryItems][search]=&ctf[GalleryItems][filter]=AlbumID_2&ctf[GalleryItems][view]=grid&ctf[GalleryItems][imagesize]=100

Line 418 in /Applications/MAMP/htdocs/silverstripe/nttanks/dataobject_manager/code/FileDataObjectManager.php

I have not modified any code, this is straight after install.

Cheers for any help!

Avatar
SheaDawson

Community Member, 46 Posts

15 March 2011 at 3:09pm

Ok problem was I had deleted the folder in the file manager. Doh!

Avatar
JonoM

Community Member, 103 Posts

4 April 2011 at 2:19pm

Hi Uncle Cheese,

I documented what I think is a bug here http://www.silverstripe.org/dataobjectmanager-module-forum/show/16435 before I realised there was a separate thread for that.

Cheers

Avatar
marcink

Community Member, 89 Posts

8 April 2011 at 7:48pm

@mdaum, could you check the "file" table in your db?
are the foldernames/paths correct?

i had the same issue and when i checked the db i noticed that the paths did not match.

Avatar
merrick_sd

Community Member, 97 Posts

3 June 2011 at 9:21pm

3 june 2011 - DataObjectmanager - live /Dev mode diferences?

I am using silverstripe 2.4.5 with DataObjectManager-master-HEAD

If the site is in dev mode my SimpleHTMLEditorField shows up :)
If the site is in live mode my SimpleHTMLEditorField doesn't show up :(

I looked at the popup frame and there are differnces
these being

   <!-- dev -->
<script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/thirdparty/prototype/prototype.js?m=1307087338"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/thirdparty/behaviour/behaviour.js?m=1307087303"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/javascript/prototype_improvements.js?m=1307087258"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/javascript/i18n.js?m=1307087255"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/javascript/lang/en_US.js?m=1307087257"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/javascript/Validator.js?m=1307087264"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/thirdparty/jquery/jquery.js?m=1307087311"></script><script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.1/jquery-ui.min.js"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/dataobject_manager/javascript/jquery.wysiwyg.js?m=1307090247"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/thirdparty/scriptaculous/scriptaculous.js?m=1307087340"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/thirdparty/scriptaculous/controls.js?m=1307087339"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/javascript/layout_helpers.js?m=1307087257"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/javascript/ComplexTableField_popup.js?m=1307087254"></script>

<!-- where as live gives -->
<script type="text/javascript" src="http://www.micromaterials.co.uk/assets/_combinedfiles/base.js?m=1307077844"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/javascript/lang/en_US.js?m=1305537654"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/javascript/Validator.js?m=1305537658"></script><script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.1/jquery-ui.min.js"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/dataobject_manager/javascript/jquery.wysiwyg.js?m=1307021392"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/thirdparty/scriptaculous/scriptaculous.js?m=1307029998"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/assets/_combinedfiles/leftandmain.js?m=1307077847"></script><script type="text/javascript" src="http://www.micromaterials.co.uk/sapphire/javascript/ComplexTableField_popup.js?m=1305537653"></script>

don't think you need this for diagnosis but

myside/code/banner.php cmsfields relevant extract

   new SimpleHTMLEditorField('BannerContent','HTML')

--

eg full code extract

function getCMSFields(){
   $source = DataObject::get("SiteTree");
   $optionArray = $source->toDropDownMap($index = 'ID', $titleField = 'Title', "--- select page ---", $sort = "Sort");
if($source) foreach( $source as $page ) {
      $optionArray[$page->ID] = $page->MenuTitle;
      }
      
      $fields = new FieldSet(
      //new DropdownField("AllSameASID","Set Links Same As",$optionArray),
      
      
   new ImageField('bannerimage','bannerimage'),
   
   new CheckboxField("sizebywidth", "LEAVE MY IMAGE Alone!! (disables auto resize on this image)"),
   new TextField('BannerAlt', 'Imag Alt'),
   new SimpleHTMLEditorField('BannerContent','HTML'),

   new DropdownField("bannerurlID","Link To Page",$optionArray)
);

return $fields;
   }
   

I can see there are diference is JS includes but how would i solve