Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Image Gallery Clean Install


Go to End
Reply

14 Posts   2083 Views

Avatar
OutrunTheWolf

10 June 2009 at 2:24am Community Member, 34 Posts

I'm having some problems with my Image Gallery, spontaneous issues which I think might be caused by installing and deleting different gallery modules.

I'd like to clean install the Image Gallery module, are there any other files I need to remove along with the module itself, just so I can get a clean install.

Thanx

Avatar
UncleCheese

10 June 2009 at 3:11am 4085 Posts

Just make sure you delete all the tables associated with those modules. I've seen that cause problems before.

Avatar
africansafari

12 June 2009 at 2:50pm Community Member, 30 Posts

I too am having similar problems after installing/re-installing image-gallery module ....

What do you mean by "Just make sure you delete all the tables associated with those modules."

Where are these tables?

I'm a newbie .......

Thanks :-)

Avatar
UncleCheese

12 June 2009 at 3:11pm 4085 Posts

Without knowing what the "problems" are exactly, my best suggestion is to remove the ImageGallery tables from the database manually before reinstalling. Silverstripe does not do a good job of cleaning up after itself.

Avatar
africansafari

12 June 2009 at 3:18pm Community Member, 30 Posts

Problems include:

pop-up not displaying properly
images appearing in single column
icon images missing in admin section went uploading images to an album ....

Are these the following tables within my database I need to delete?

ImageGalleryAlbum
ImageGalleryItem
ImageGalleryPage
ImageGalleryPage_Live
ImageGalleryPage_versions

... just want to ensure I delete correct ones :-)

thanks

Avatar
africansafari

12 June 2009 at 3:20pm Community Member, 30 Posts

in addition to the above ... am currenlty in myphpadmin section ... not sure if I can delete these tables.

There is an option to 'empty' - is that the same idea?

Thanks.

Avatar
africansafari

12 June 2009 at 8:37pm Community Member, 30 Posts

I have uninstalled, cleaned up tables (which I think I have done correctly) and reinstalled image-gallery, but no luck getting image-gallery to work.

Check out these 2 screenshots - as shows how I can't upload images.

Help .... please :-)

Thanks.

Avatar
UncleCheese

13 June 2009 at 1:21am 4085 Posts

Yuck. Looks like none of the CSS and JS dependencies are coming in. Make sure the module folder is called "image_gallery" and it is in your Silverstripe root. Same with "dataobject_manager" and "swfupload".

Go to Top