Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

swfUpload Error "There was a problem with the upload. The server did not accept it."


Go to End
Reply

10 Posts   9226 Views

Avatar
Toast

14 July 2009 at 11:10am Community Member, 3 Posts

I keep getting the error below when using the swfUpload.

"There was a problem with the upload.
The server did not accept it."

I've found disabling mod_security by adding "SecFilterEngine Off" to my .htaccess file got it working.

Anyway, I hope this helps someone.

Avatar
WillSkeggs

28 July 2009 at 11:34am Community Member, 3 Posts

We had the same problem, however it turned out to be the max post size setting in php.ini was too small for the files we were trying to upload.

:)

Avatar
moloko_man

11 September 2009 at 5:40am (Last edited: 11 September 2009 5:42am), Community Member, 72 Posts

I have the same problem and when I disable mod_security in the .htaccess file I get a 500 Server error, and when I add it to my php.ini file I still get the same error:

"An Error occurred in the upload. Try again later."

Then:

"There was a problem with the upload.
The server did not accept it."

Is there somewhere else where I can fix this?

btw, I'm using the DataObjectManager Module with swfUpload and ImageGallery modules.

Thanks

Avatar
UncleCheese

11 September 2009 at 6:11am 4085 Posts

Yeah, it's a brutal error to troubleshoot, and it happens for a number of reasons. Unfortunately, Flash can't report verbose PHP errors, so all you get are status codes. You can packet sniff with Wireshark to get the output of the response. I'm hearing less and less of it happening lately, and the only thing that seems to cause it is mod_security, so be sure your server will allow you to disable mod_security in .htaccess. A lot of hosting providers won't allow that.

There's a write up on how to troubleshoot this error in the docs. Tedious, but at least you can find out where the problem is.

http://doc.silverstripe.com/doku.php?id=modules:swfuploadfield&s=swfupload#troubleshooting

Avatar
pinkp

26 March 2010 at 6:24am Community Member, 168 Posts

"I've found disabling mod_security by adding "SecFilterEngine Off" to my .htaccess file got it working. "

This also worked for me, are there any long term effects from such a fix? Thanks

Avatar
tbarho

21 June 2010 at 5:23pm Community Member, 41 Posts

Has anyone had this happen right out of the box with 2.4 on the Files & Images tab? If so, any fix?

Avatar
wainui

23 July 2010 at 8:36pm Community Member, 56 Posts

Hey guys, in case someone having same issue with server (tracked down to fie size).
my problem was fixed by also increasing the post_max_size in my php.ini file.

Avatar
UncleCheese

24 July 2010 at 1:58am 4085 Posts

Yeah, that's a less common fix, because the SWFUpload module is designed to block any files that are larger than your php allowed size. But sometimes it's not always accurate.

Go to Top