Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

problems getting started with the dataobjectmanager


Reply

5 Posts   833 Views

Avatar
snoopy

29 August 2009 at 9:07am Community Member, 4 Posts

hi!
I'm new to SS.. so far I really like it! installation and first steps went all fine, but now I'm having trouble:

I just installed the dataobjectmanager module and tried to follow the tutorial...
created the Testimonial.php and TestimonialPage.php, but after running dev/build and flush I still cannot see any changes to the cms...
except one: when clicking on files & images I get an error, because I didn't manage to install the SWFupload so far... :-(

I also checked the file permissions, but that didn't help..

thank you very much for your help!

Avatar
banal

29 August 2009 at 9:38am Community Member, 901 Posts

Hi

Hmm. Actually, you should now be able to create a Testimonial Page.. does it show in the Page dropdown when you click on "Create"? If not, maybe a /admin/flush=1 will help.

Avatar
snoopy

29 August 2009 at 9:53am Community Member, 4 Posts

Hi and thanks for your reply!

I tried admin/?flush=1, but nothing changed. I can only select Page, Error Page, Virtual Page and Redirector Page.

I'm wondering: when I run /dev/build there's a list of database tables displayed - shouldn't this TestimonialPage be listed there as well? I can find Page, ErrorPage and so on, but no Testimonial..

Any other ideas?

And can anyone also help with the swfupload, please? I downloaded version 2.2.0.1, placed it in my silverstripe root folder and ran dev/build, but I still get the complaints, that swfupload is required..

tia!

Avatar
banal

29 August 2009 at 5:51pm Community Member, 901 Posts

Hm that's strange. Where did you put the Testimonial.php and TestimonialPage.php files? Could you post the contents of the TestimonialsPage.php?

Avatar
snoopy

31 August 2009 at 12:12am Community Member, 4 Posts

I put the files in /mysite/code within silverstripe root directory.

In the meantime I tried a lot of things that were suggested elsewhere in this forum... I learned that the dataobject_manager and swfupload folder really need to be spelled exactly like this and I also downloaded an swf version that was suggested for download in one of the threads.

This solved all my issues.

Thank you very much for offering your help banal! I really appreciate that.

Who is responsible for updating the tutorials? I'd argue that pointing out that the exact spelling of folder names is important, would hellp people save a lot of time. I was neither the first nor the last to have this kind of problem, I guess :-)