Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

DatePickerField not popping up calendar


Reply


30 Posts   6246 Views

Avatar
Shawn Parr

Community Member, 60 Posts

10 September 2009 at 7:56am

Is the popup really a part of DOM, or is there a popup controller in the base SS install? We are having a lot of trouble hunting this down, and it is very weird:

If we create a new install, then the popup will work, until we do a ?flush=all then it no longer works. Whenever it doesn't work getting the source of the popup shows that the main jquery file from jsparty is not in the list of scripts to load.

Since it works, then stops, we started looking into caching, manually deleting SS caches, making sure apache wasn't caching, making sure to clear browser caches religiously, etc. Still no dice.

We are actively digging around in things, but we are feeling pretty lost on this. It is really weird to upgrade an existing site by using an svn switch, and it doesn't work, while creating a new site, and finishing the install by using the exact same svn switch works fine. Until you flush.

I tried doing a flush on your demo sites, and of course they survived just fine. Apparently 2.3.3 is just not for us or something. It's also weird as everytime we think of a new possibility, we can pretty easily discount it (reverse proxy issue, nope test server isn't behind the proxy, APC issue, nope test server doesn't use APC, etc, etc).

Avatar
Shawn Parr

Community Member, 60 Posts

11 September 2009 at 9:49am

Okay, I got this working. It still doesn't make sense why it wasn't working, but now it is, I had the make the following changes:

DataObjectManager.php, line 495:

Requirements::javascript('jsparty/jquery/jquery.js');

to

Requirements::javascript($this->BaseHref() . 'jsparty/jquery/jquery.js');

DatePickerField.php, line 70:

Requirements::javascript("jsparty/jquery/plugins/livequery/jquery.livequery.js");

to

Requirements::javascript($this->BaseHref() . "jsparty/jquery/plugins/livequery/jquery.livequery.js");

And finally I had to comment out SimpleTinyMCEField.php line 216. That was pulling a different version of jQuery (1.3) that was conflicting with the jsparty version.

That being said, the above code should all work, as jsparty is in the same place no matter what. So I'm not sure what in my system is making it not fulfill the requirements statements when they are normal relative references. But it only seems to happen inside the DOM files, and it is consistent across a couple different servers and quite a few sites.

The weirdest part is that it seems like any requirements statement works, unless it is pointing at a file inside of jsparty. I'm a bit baffled why that would be the case. But at least for now we have it working, and in the future I have something to keep my eye out for in testing.

Avatar
UncleCheese

Forum Moderator, 4096 Posts

12 September 2009 at 1:22am

There is another user who experienced this problem. It would be interesting to see what your configurations have in common. That the pathing problem only applies to that one file is quite mind-boggling.

In the meantime, I've updated SimpleTinyMCEField to use the standard jquery file in jsparty.

Avatar
cygnet

Community Member, 20 Posts

12 September 2009 at 2:44am

to Shawn Parr: it seems that we have something in common, because after applying your fixes I have datepicker pop-up working as well

Avatar
Shawn Parr

Community Member, 60 Posts

12 September 2009 at 2:53am

Intriguing. Feel free to drop me a line at parrs at nsula dot edu and we can chat about configs that would probably be a bit more intense than this forum would like. :)

Avatar
UncleCheese

Forum Moderator, 4096 Posts

12 September 2009 at 3:35am

And definitely keep me in the loop with your discoveries. Just post them on this thread. Thanks.

Avatar
cygnet

Community Member, 20 Posts

12 September 2009 at 4:47pm

ok. I'm going on holidays tomorrow, but once I get back, I'll drop you a line.

Avatar
malinux

Community Member, 23 Posts

13 September 2009 at 4:46am

Edited: 13/09/2009 4:49am

Hi UncleCheese

I had the same datepicker popup problem and followed Shawn Parrs suggestion and now it works for me. See me configuration here:

http://www.silverstripe.org/all-other-modules/show/268708?start=0#post268886