Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Trouble with MP4's


Reply


3 Posts   1322 Views

Avatar
vstrazz

Community Member, 63 Posts

16 October 2009 at 3:54am

Hey guys,

When I upload an MP4 video, the DOM seems to get confused sometimes and add it as audio. I have it set in the allowed file types in FLV.php and in the page I'm using the DOM on.

Any Ideas?

Avatar
UncleCheese

Forum Moderator, 4096 Posts

16 October 2009 at 6:20am

I don't see how that could happen. A file gets upgraded to the MP3 class based on its extension matching the $allowed_file_types array in the MP3 class. The only value in there is 'mp3', so I don't know how mp4 would sneak through as a false positive.

Is the file being stored in the File table with ClassName MP3?

Avatar
vstrazz

Community Member, 63 Posts

16 October 2009 at 7:48am

It's weird, I just uploaded the same MP4 that did it earlier and I cant get the issue to duplicate. The next time it comes up I will check the class.

It would show the icon for the file as the sound icon and not let me attach it to my video DOM. ( which only allows certain file types, mp4 included ).

I will check the DB next time, I tried to duplicate it twice with no success though.