Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Image uploading not working - javascript error


Go to End
Reply


12 Posts   3034 Views

Avatar
Viv

Community Member, 30 Posts

12 November 2009 at 9:34am

Edited: 12/11/2009 10:16am

Hi,

Have just created a new site with SS 2.3.3 and have uploaded the latest image gallery modules:

modules-image_gallery-r314
modules-dataobject_manager-r320
modules-swfupload-r271

All seems to be working until trying to upload an image to an album. Nothing appears in the upload box (ie. no form to upload anything). When I checked the javascript Error Console in Firefox I see the following error:

Error: illegal XML character
Source file: http://www.mysite.co.nz/dataobject_manager/javascript/dataobjectmanager_popup.js
Line: 4, Column: 1
Source code: <<<<<<< .mine

I have other (earlier) installations of the Gallery working OK on other sites (excellent module by the way!). Any help here would be appreciated.

Thanks.

Avatar
Platypus

Community Member, 43 Posts

12 November 2009 at 9:44am

Edited: 12/11/2009 9:48am

After updating to DOM r320 I get the same issue, nothing appears inside the upload box.

And I had to set "allow_assets_override" to "false" because I ran into this, when I tried to go to "Files & Images":

Fatal error: Out of memory (allocated 30408704) (tried to allocate 4864 bytes) in .../sapphire/core/Object.php(665) : runtime-created function on line 1

Avatar
Viv

Community Member, 30 Posts

12 November 2009 at 9:57am

Tried changing the "allow_assets_override" to "false". I can now use the "files and images" section to upload files now with the normal upload system. However these files are not linked in to the image gallery so do not appear in there or on the final image gallery pages.

Still getting the empty box with the image gallery "upload photos" section...

Avatar
UncleCheese

Forum Moderator, 4096 Posts

12 November 2009 at 10:15am

Yikes... looks like an SVN conflict somehow worked its way into the trunk. Run another update and you should be good.

Avatar
Viv

Community Member, 30 Posts

12 November 2009 at 10:20am

Edited: 12/11/2009 10:27am

Sorry, do you mean get and install the latest version (DailyBuild?) of the SS Core?

PS: Just added to my original post that it says the error is: "illegal XML character"

Avatar
UncleCheese

Forum Moderator, 4096 Posts

12 November 2009 at 10:41am

No, update your DataObjectManager SVN.

Avatar
Viv

Community Member, 30 Posts

12 November 2009 at 12:44pm

Thanks very much, did that and all good!

Avatar
Platypus

Community Member, 43 Posts

12 November 2009 at 11:17pm

Edited: 12/11/2009 11:18pm

Thanks UncleCheese, DOM r322 fixed the upload box.

But I still can't use "allow_assets_override". If I set this to "true" I can't access my Files & Images, resulting in in out of memory errors like the one posted above.

Or like this:

Fatal error: Out of memory (allocated 30408704) (tried to allocate 19456 bytes) in .../sapphire/forms/TreeDropdownField.php on line 98

Fatal error: Out of memory (allocated 30408704) (tried to allocate 48 bytes) in .../sapphire/core/Object.php on line 580

Thanks for you're help! Platypus

Go to Top