Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

2.4 alpha1 compatibility?


Go to End
Reply


13 Posts   1732 Views

Avatar
Cem

Community Member, 31 Posts

21 November 2009 at 12:24pm

Hi,
Does the Image Gallery module work with 2.4 alpha?
Or is it still early?
Cheers

Avatar
UncleCheese

Forum Moderator, 4092 Posts

21 November 2009 at 2:09pm

I wouldn't count on it. But if you want to test it and post your results, it will save me a lot of time!

As excited as I am about 2.4, I'm dreading upgrading all my code. :(

Avatar
wmk

Community Member, 46 Posts

25 November 2009 at 1:09am

Well, it works so far, but i cannot edit the images i uploaded (using code that worked in 2.3.3):

SecurityID doesn't match, possible CRSF attack.

Here is my code for "simple gallery pics"

$manager = new FileDataObjectManager(
$this, // Controller
'GalleryPics', // Source name
'GalleryPic', // Source class
'Attachment', // File name on DataObject
array(
'Title' => 'Titel',
'Description' => 'Beschreibung',
'Copyright' => 'Copyright / Quelle'
), // Headings
'getCMSFields_forPopup' // Detail fields (function name or FieldSet object)
// Filter clause
// Sort clause
// Join clause
);

Images are uploaded but i cannot edit title, description etc.

I run 2.4.0alpha1 (the tar.gz) and DOM r330.

Hope this helps ;)

WMK

Avatar
UncleCheese

Forum Moderator, 4092 Posts

25 November 2009 at 2:22am

Yeah, this is going to be the biggest hurdle. I've been working on this one for weeks. Have a call with Ingo next week to see if he can point me in the right direction. I've tracked it down to some logic in the loadDataFrom() method in the Form class that seems erroneous to me, but we'll see.

Avatar
Miles

Community Member, 14 Posts

1 December 2009 at 5:49am

I'm running into this same issue on the events calendar as well. Have you been able to make any progress with it UncleCheese?

Avatar
UncleCheese

Forum Moderator, 4092 Posts

1 December 2009 at 6:11am

I have a call scheduled with Ingo this week. I hope to get a patch in very soon.

Avatar
UncleCheese

Forum Moderator, 4092 Posts

2 December 2009 at 10:36am

UPDATE: I've spoken with Ingo, and he has confirmed the bug, going all the way down to the ViewableData class. He's going to do some unit tests and put in a patch soon. I'll post the ticket once it's in the system.

Thanks for you patience, everyone! For once, this is a bug I can blame on someone other than myself! :)

Avatar
Miles

Community Member, 14 Posts

2 December 2009 at 11:07am

Thank you for your very hard work on this!

Go to Top