Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Tax Modifier not working without dev/build


Reply


3 Posts   1470 Views

Avatar
pjonathan

Community Member, 9 Posts

9 February 2010 at 6:37pm

Hi all, I developed a site using SilverStripe 2.3.4, eCommerce build 0.6, PayPal gateway.

I am using the tax modifier, which seems to work only after running a dev/build. If I try on a different computer, or even a different browser on the same computer, the checkout page does not make any mention of the tax, and Paypal shows the tax as the following: 0.0% (included in the above price), even though it is set at 13% and exclusive. Something must be right, since after the dev/build suddenly things work as they should.

If someone has ANY idea as to what might be wrong, or how I could go about figuring out what may be wrong, I'd really appreciate it.

Thanks in advance!

Avatar
pjonathan

Community Member, 9 Posts

14 February 2010 at 6:45pm

Hello,

I've realized the issue isn't related to dev/build, but rather, the taxmodifier only seems to work when I'm logged in as Administrator.

Presumably when I am logged in, the system recognizes my country before the checkout form is filled in, and is able to determine the appropriate tax amount. Any ideas of what a possible work around would be? Perhaps defining a default tax amount would fix this? I've tried some things but I'm not exactly sure how to go about that (clearly I'm quite new with PHP).

Would be grateful for any help at all, thanks team

Avatar
memmu

Community Member, 2 Posts

17 June 2010 at 9:19pm

Edited: 18/06/2010 9:48pm

Hi. I have the same problem with you. Tax only shows 0.0% in PayPal, but there is no mentioning about tax in the actual ecommerce. Did you find a solution for this?

I have added following to mysite/_config.php:

Order::set_modifiers(array(
'TaxModifier'
));

TaxModifier::set_for_country("UK", 1.0, "VAT", "exclusive");
TaxModifier::set_for_country("FI", 0.15, "VAT", "inclusive");

I think there is something wrong with the TaxModifier.php what is not picking the rate.
Anybody have any ideas?

Instructions would be nice...Thanks