Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

E-Commerce Module 2.4 Beta Compatible?


Reply


3 Posts   1574 Views

Avatar
MorayWeb

Community Member, 1 Post

25 February 2010 at 10:31am

I have been holding off using SS for projects as I like to use 'friendly' urls on the sites I develop, and thanks to the 2.4 beta I can now get stuck in! :)

I have a couple of sites in the pipeline that would benefit from using the E-Commerce module, but when I tried installing it I get an error on rebuilding the database - "Notice: DataObjectDecorator::extraDBFields() is deprecated. Please use extraStatics() instead."

Is this an incompatibility in the E-Commerce module with SS2.4 or is there something else I am not doing, or required modules etc...

Any help appreciated!

Regards,

Gordon

Avatar
HansR

Community Member, 140 Posts

26 February 2010 at 5:52pm

Are you sure that these were errors and not warnings? Deprecated functions are functions that shouldn't be used in new code, but should still work. So, this shouldn't stop the module from working.

I had a quick search for "extraDBFields" in the e-commerce code, and none of the classes have this method. So, this warning is probably generated by another module.

Hans

Avatar
Rawish

Community Member, 5 Posts

2 July 2010 at 4:20pm

Hello,

Got the same warning and yes it is just a warning. Disable dev mode and it is fine. My problem is now, is it also possible to disable this specific warning in dev mode? This because this is the first from more to occur and this way I'm not able to work down my full site in dev mode.