Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

E-Commerce Modules

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Working on e-commerce for SS 2.4


Reply

121 Posts   13492 Views

Avatar
ChrisS

3 June 2010 at 2:06pm Community Member, 5 Posts

Hi there wainui.

https://code.google.com/p/silverstripe-ecommerce/ is a link to the google code site for silverstripe-ecommerce. SVN instructions are under the Source tab there.

Avatar
wainui

3 June 2010 at 3:14pm Community Member, 56 Posts

found it...
for anyone else who is keen the link is

svn checkout http://silverstripe-ecommerce.googlecode.com/svn/trunk/ ecommerce

Avatar
biapar

3 June 2010 at 7:44pm Forum Moderator, 435 Posts

Important link:

http://doc.silverstripe.org/datamodel

http://doc.silverstripe.org/dataobject

Avatar
biapar

5 June 2010 at 2:23am (Last edited: 6 June 2010 12:36am), Forum Moderator, 435 Posts

Is it possible to post trunk zip file?

Avatar
mattconfusion

10 June 2010 at 9:42pm (Last edited: 10 June 2010 10:17pm), Community Member, 48 Posts

I'm using the latest e-commerce 0.6.1 beta and SS 2.4, reports are ok (I was looking for them in the wrong place before)

Avatar
Jedateach

10 June 2010 at 10:17pm (Last edited: 10 June 2010 10:20pm), Forum Moderator, 227 Posts

@mattconfusion - Ok, good to hear.

Don't forget you can submit any feature requests / patches etc at https://code.google.com/p/silverstripe-ecommerce/issues/list

Avatar
mattconfusion

10 June 2010 at 10:55pm Community Member, 48 Posts

thanks found it! I get an error on the invoice link. The Invoice.ss template is not found

Avatar
Jedateach

10 June 2010 at 10:59pm (Last edited: 10 June 2010 10:59pm), Forum Moderator, 227 Posts

I've uploaded the Invoice.ss template update via SVN and it should now work.

Thanks for finding that.