Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Order Reports not showing + problems with proceed order


Reply


2 Posts   854 Views

Avatar
mattconfusion

Community Member, 48 Posts

10 June 2010 at 1:34am

How backoffice issues are managed under the E-commerce module? I guess it's done from the order Reports showing on the cMS interface. Ok, well, I see product reports, featured products report but no order reports generated. Could it be that there are no Orders placed? Trying to place an order gives me the error already reported

Source

148    /**
149     * @todo Improve documentation
150     */
151    static function ancestry($class, $onlyWithTables = false) {
152       global $_ALL_CLASSES;
153
154       if(is_object($class)) $class = $class->class;
155       else if(!is_string($class)) user_error("Bad class value " . var_export($class, true) . " passed to ClassInfo::ancestry()", E_USER_WARNING);
156
157       $items = $_ALL_CLASSES['parents'][$class];
158       $items[$class] = $class;
159       if($onlyWithTables) foreach($items as $item) {
160          if(!DataObject::has_own_table($item)) unset($items[$item]);
161       }
162       return $items;
163    }

Trace

Catchable fatal error: Method Order_Item::__toString() must return a string value

I'm using SS 0.5.4 with silverstripe 2.3.7, downgraded from 2.4 because it was not working. The trunk gets errors on installation.

Someone could suggest me somthing to do???

Avatar
biapar

Forum Moderator, 435 Posts

11 June 2010 at 2:42am

Try to use last ecommerce trunk with 2.4.
Download link here: http://www.silverstripe.org/e-commerce-module-forum/show/285922#post285922