Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

E-Commerce claims older support for 2.3 but requires Payment module which doesn't work for 2.3


Reply


2 Posts   477 Views

Avatar
bostonmark

Community Member, 10 Posts

25 September 2011 at 3:35am

Hi all,

I'm running a site on SilverStripe 2.3.11 and would like to use the E-Commerce module. The module has an older release that would satisfy my version requirement:

Version: [v0.6.1]
Date: 2009-06-18
Compatible with: SilverStripe 2.3
Download: ecommerce-0.6-beta2.tar.gz

I tried to install this but got an error about Payment not existing. The E-Commerce module claims it requires the Payment module as well. Fine by me, so I tried to find a release of the Payment module that works on SilverStripe 2.3.11 but no releases listed show that kind of support. My ultimate question is, how can the E-Commerce module work for 2.3 if there's no Payment module that works with 2.3? Am I missing something?

I appreciate any help you can provide. Thanks in advance.

Avatar
Ryan M.

Community Member, 309 Posts

25 September 2011 at 9:05am

You can try installing it anyways. If anything's wrong with it you could just get your hands dirty and fix it yourself, if you're programatically inclined.