Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

How do I install the E-Commerce Module


Reply


5 Posts   4779 Views

Avatar
ccisco

Community Member, 2 Posts

16 December 2008 at 9:52pm

Hi to all,

sorry for this really simple question but how do I install the module. I just dragged the fresh downloaded and extracted ecommerce folder in the silverstripe folder, refreshed both the frontend and backend but still I can't get access to the module. In the backend it appears a "report" icon at the top but when I click on it it shows only this error message:

Fatal error: Class 'Report_StatsReport' not found in D:\xampp\htdocs\silverstripe\cms\code\ReportAdmin.php on line 70

I'm grateful for any given help!

Avatar
Nivanka

Community Member, 400 Posts

16 December 2008 at 11:48pm

did you install it?

to install you have to go to a url similar to the following.

http://mysite.com/db/build?flush=1

if you didnt install, try installing first.

Avatar
ccisco

Community Member, 2 Posts

17 December 2008 at 12:31am

Edited: 17/12/2008 12:32am

No, I didn't install it because I didn't know how to install modules in SilverStripe. Thanks to your post I installed it, yipii! :-) I tried to find a 'how to install modules' here on the website but I didn't find anything like that...

Avatar
smartinet

Community Member, 9 Posts

23 January 2009 at 5:36pm

Stupid question, but when I extract the package, it extracts as follows:
\modules\ecommerce\tags\0.5.2\code ..etc

So please tell me, is is the modules, the ecommerce or the 0.5.2 folder contents that need to end up in the root of my SilverStripe install?

I've been running the db command over and over and can't get the module to install, so I think it's a path issue. This would mean either the package or instructions are incorrect.

Avatar
smartinet

Community Member, 9 Posts

23 January 2009 at 5:42pm

Ok, forget that.

For other newbies like me, you must extract the 0.5.2 (or whatever current version) folder in the zip and place them in a folder called 'ecommerce' in the root of your SilverStripe install.

Then run the db command above.

The zip package is unnecessarily crammed with folders that aren't required, so if you follow the instructions to just unzip in your root it won't work.

If you've extracted correctly, it should be :
[silverstripe root]/ecommerce/code
[silverstripe root]/ecommerce/css
...etc...

Documentation is a wonderful thing...!