Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

E-Commerce 0.6 beta 1 released


Reply


108 Posts   20660 Views

Avatar
Polawat

Community Member, 4 Posts

19 September 2009 at 7:24am

I got it working with Paypal. I tested it on the Paypal sandbox, got to the successful payment page on Paypal. When I click on the Return to Store button. It just keep loading and never leave the Paypal page and seem to freeze there. Then, I can no longer access my site with this same browser session (even if I open a new tab). I have to close the browser altogether and open it back again in order to access my Silverstripe site.

I'd appreciate if anyone can tell me how I can fix this.

Thanks!

Avatar
petejeveritt

Community Member, 5 Posts

20 September 2009 at 6:53am

Hi there,

I've been trying to get this ecommerce module installed but keep on hitting a brick wall. I get the error:
Website Error
There has been an error

The website server has not been able to respond to your request.

This happens everytime I run /dev/build (inc ?flush=1). I have tried installing both ecommerce and payment module seperately and end up with the same result. I'm running SS 2.3.3.

I've run out of ideas as what to do - any help appreciated!

Pete.

Avatar
Jedateach

Forum Moderator, 233 Posts

20 September 2009 at 8:29am

petejeveritt: run your site in dev mode, or set up an admin email, and you'll be able to find out what that error actually is.

see http://doc.silverstripe.com/doku.php?id=debugging

Avatar
petejeveritt

Community Member, 5 Posts

20 September 2009 at 10:21pm

Many thanks - you're a life saver!

I'm a bit of a newbie and wouldn't have thought of that!

Thanks again.

Pete.

Avatar
petejeveritt

Community Member, 5 Posts

22 September 2009 at 9:36am

just got another couple of questions:

1. I'm wanting to remove the cart option as I'm installing the module for a client who hosts parties (i.e. they want to advertise their products, but not sell them via the web) how can I do this as I cannot seem to find the code that controls the "my cart" displaying on the sidebar. Is this possible?

The second question may not be for this forum, but I have put 2 images on the header and nav of the site, and SS is insistant on putting a slight grey line around them - is there any way I can get rid of this?

If you want to see what I mean check out http://www.time4silver.co.uk

Many thanks,

Pete.

Avatar
Jedateach

Forum Moderator, 233 Posts

22 September 2009 at 9:57am

Hi Pete,

To get rid of the "my cart" part, you'll need to find the template (.ss) file within the ecommerce templates folder that contains the "my cart" html. Make a copy of it, and put it in your own template directory. Make the necessary changes, and this will override the old template.

As for the images, I don't see any grey line.

Jeremy

Avatar
jhirm

Community Member, 21 Posts

2 October 2009 at 4:56am

I apologize if this has already been addressed -

I was very happy to see that this release of the E-Commerce module used jQuery instead of prototype, but blocking all the prototype js in the checkout page also breaks the AJAX validation... is there a plan to add validation via jQuery? For now I've done it manually, but it would be nice if it happened automatically.

Avatar
Jedateach

Forum Moderator, 233 Posts

2 October 2009 at 8:46am

jhirm: I believe the next version of SS (2.4) aims to use jQuery for validation.