Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Forum Module /

Discuss the Forum Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

"Ghost" Anonymous User


Reply


5 Posts   1580 Views

Avatar
jacobsjensen

Community Member, 20 Posts

9 January 2010 at 10:55am

Hi, I've got a forum set-up where I've set the forum(s) not to allow any un-authorized viewing or commenting... But I still get an "Anonymous user" in the footer where it says: Currently Online: Anonymous user, Jacob

Any ideas on what could cause this??

I've attached a screendump of my access settings on one of the forums...

Attached Files
Avatar
Willr

Forum Moderator, 5513 Posts

9 January 2010 at 2:53pm

You don't actually happened to be logged in do you?. It will show anon if a member whos logged in doesn't have a Nickname and usually the admin member doesn't have a nickname by default.

Avatar
jacobsjensen

Community Member, 20 Posts

9 January 2010 at 10:39pm

Hi,
No, I've quit all browsers, and logged in via the frontend with my Forum user (nickname: Jacob), It now says: Currently Online: Jacob, Anonymous user

Any ideas?

Avatar
Willr

Forum Moderator, 5513 Posts

10 January 2010 at 10:51am

Well it does check for members who have been logged in in the past 15mins rather then just now. You might want to play around with the INTERVAL code in forum/code/ForumHolder.php in the CurrentlyOnline function.

Avatar
jacobsjensen

Community Member, 20 Posts

10 January 2010 at 11:18am

Spot on!

That did the trick! :-)

Thank you big time!

Now I only need to style my forum as nice as this one, and take the time to translate it all to danish :-D ... But why not, then it's done and the danish silverstripe user can enjoy a great module too!