Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Forum Module /

Discuss the Forum Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

forum_startTopic.gif - where is it in the code?


Reply


3 Posts   1028 Views

Avatar
jacobsjensen

Community Member, 20 Posts

11 January 2010 at 5:07am

Edited: 11/01/2010 5:10am

Hi,
I've just finished translating the forum module to danish and is now trying to point out all hardcoded elements text and images.
BUT the last thing I need to get rid of is the file startTopic.gif - saying "+Start a new topic".

Anyone have an idea where it's located? I can se that you guys (the Silverstripe Team) has it as text and css instead... Where to find it... I've made a site-wide search in all files, but no luck...

I can see that some translations are missing on translate.silverstripe.org. I've manually added them to my da_DK.php file after downloading it from the translation site. - Is there any way I can add them to the translation site myself?

Furthermore all the namespaces in the _t('POSTS','Posts') are totally left out in all the .ss files... Any reason for this? Resulting in missing translations...

Avatar
Willr

Forum Moderator, 5513 Posts

11 January 2010 at 9:07am

The image is in in forum/Templates/Layout/Forum.ss.

Is there any way I can add them to the translation site myself?

If they aren't in the file then we probably have to run the text collector task and update the en_US.php file when every other language is based off. I think thats how the translation server works.

Avatar
jacobsjensen

Community Member, 20 Posts

14 January 2010 at 10:04am

Hi Will,

Can't figure out why Dreamweaver didn't find that image :-)
Another question on where to find something... the "POST" submit button... It seems to be the last thing I need to prepare for translation... I'll try to run the text collector when I finish...