Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Forum Module /

Discuss the Forum Module.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Losing Forum details when adding a user to another group


Reply


4 Posts   1063 Views

Avatar
HansR

Community Member, 140 Posts

17 June 2009 at 5:01pm

I have a website with multiple security groups, and I've been manually adding some forum users to another group for access to restricted areas. However, when doing this, I've been losing the forum fields (nickname, etc.). What's happening is that the autocomplete only autocomplete's the basic fields, and leaves the forum ones blank. After adding, it update's the user's records, deleting all of the forum fields. A workaround is to memorize the user's details (or leaving the details open in another window), and enter them manually, but that's definitely an annoying way to work

I would submit a ticket, but I'm not sure which module is the problem here. I also wish that there were a more intuitive method of adding a user to multiple groups; for example, a group edit box in the edit user window.

Hans

Avatar
Howard

Community Member, 215 Posts

17 June 2009 at 5:24pm

Wow I am having a very similar issue, not the forum exactly but iv extended the member object. I am hoping tomorrow to have a chance to re-write the security interface using modeladmin so that i have a list of all members then within the popup have a tickbox field which selects the groups that member is in.

It might be a bit tricky but ill let you know how i go.

Avatar
Willr

Forum Moderator, 5513 Posts

17 June 2009 at 8:20pm

I would submit a ticket, but I'm not sure which module is the problem here. I also wish that there were a more intuitive method of adding a user to multiple groups; for example, a group edit box in the edit user window.

I would think you are on the right track here. I would assign it as a CMS Security section bug as the forum (and other modules) shouldnt need to worry about this functionality and managing a user with multiple groups would be a much better way to solve the issues you have as well.

Avatar
HansR

Community Member, 140 Posts

19 June 2009 at 12:43pm

I've submitted two tickets, Ticket #4263 and Ticket #4264. Ticket #4263 is about the auto-complete issue, which should be fixed regardless of whether there is an easier way to add users to another group. Ticket #4264 is about editing the group memberships directly.

Hans